Вступление

Мысль сделать справочный файл по собранным советам витала в воздухе уже давно. Наконец, она нашла воплощение в жизнь. Обусловлено это прежде всего удобством для посетителей сайта: нет необходимости лишний раз обращаться к интернету за поиском нужной информации, тем более не всегда есть доступ к нему в данный момент, а сведения понадобились срочно, да и поиск нужных данных по такому файлу гораздо удобнее.

Частично, на создание такого файла нас подтолкнула замечательная идея Александра Рыжова (http://www.sovety.net), примерную структуру которого мы также слегка заимствовали (да не сочтет он нас плагиатором, просто такая великолепная идея пришла ему в голову первому).

Что вы здесь найдете:

  • большую часть архива советов сайта http://www.webhowto.ru

Что вы не найдете:

  • самые последние советы. Ориентировочный период обновления файла - 2 месяца. Все, что будет добавлено между обновлениями вы найдете на сайте;
  • советы, касающиеся реестра. Справку по реестру можно скачать на сайте: http://winchanger.narod.ru

Хотелось бы поблагодарить всех, присылавших свои советы (Список наиболее активных приведен в разделе Авторы). Без вас эта подборка не была бы такой интересной и объемной!

© 2002 И. Чеботарев, А.Климов
http://www.webhowto.ru/reg
http://winchanger.narod.ru


Новые советы

http://www.whatis.ru/
http://winchanger.narod.ru/

"Народная мудрость" - новые советы

Terminator II

Чтобы отключить встроенный динамик в Windows XP (достал, однако), то...Подробнее >>

Сергей Трошин

Windows XP сама создает свои подпапки в папке Мои документы (My Pictures, My Video и др.). При удалении этих папок они создаются заново! Если вам не нравится подобное поведение, то надо...Подробнее >>

Terminator II

Если у тебя есть домашняя страничка, и ты не хочешь, чтобы поисковые роботы индексировали твою страничку с секретной информацией...Подробнее >>

Сергей Трошин

Можно сделать так, чтобы при загрузке Windows XP система запрашивала ключевую дискету с паролем и лишь после ее установки можно было бы вводить имя пользователя...Подробнее >>

Terminator II

Чтобы переназначить диски в Windows XP...Подробнее >>


Windows: Общие советы

Windows XP сама создает свои подпапки в папке Мои документы (My Pictures, My Video и др.). При удалении этих папок они создаются заново! Если вам не нравится подобное поведение, то надо лишь выполнить команду
regsvr32 /u mydocs.dll
и подпапки создаваться не будут. А если захотите вернуть все обратно, то введите в командной строке следующее:
regsvr32 mydocs.dll

Можно сделать так, чтобы при загрузке Windows XP система запрашивала ключевую дискету с паролем и лишь после ее установки можно было бы вводить имя пользователя. Для этого используется утилита syskey, которая дополнительно шифрует базы данных учетных записей, требует ввода пароля при загрузке системы (еще до logon). По умолчанию такой пароль не требуется, так как он хранится на жестком диске. Если же вы хотите максимально ужесточить политику защиты учетных записей, то в строке "Выполнить" меню кнопки Пуск введите Syskey, в появившемся диалоговом окне нажмите кнопку "Обновить" и в разделе "Генерируемый системой пароль" вы получите возможность выбора места хранения пароля - на локальном диске (используется по умолчанию) или на дискете. Здесь же можно выбрать пункт "Пароль запуска", и тогда при загрузке системы придется вводить ключевое слово вручную - в этом случае пароль должен храниться в памяти пользователя. Учтите только, что такую операцию лучше все же проводить на чистой, только что установленной системе, потому как в этом случае вероятность появления каких-либо сбоев минимальна

Чтобы переназначить диски в Windows XP нужно проделать несколько операций. Для начала о причине, по которой может понадобиться переименовывать диск. Дело в том, что при установке Windows XP присваивает буквы дискам по порядку обнаружения и после они уже не меняются. Может случиться такая ситуация, что загрузочному присваивается C, далее D, последняя буква присваивается приводу CD, (например, Е). При подключении нового винчестера систем присвоит ему букву, следующей за Е. В результате пользователи немного путаются, привыкнув по предыдущим версиям, что CD-ROM всегда последний. Итак, вызываем "Управление компьютером" (Пуск-Выполнить-compmgmt.msc). В появившемся окне выбираем пункт "Управление дисками" и щелкаем правой кнопкой - Выбираем пункт Изменить букву диска

Знаете ли вы, что в Windows XP можно создать загрузочную дискету MS-DOS? В контекстном меню флоппи-диска выберите команду Форматировать, а затем - Создание загрузочного диска MS-DOS

Если вы привыкли удалять файлы путем переноса их мышкой в корзину, то вам, вероятно, неудобно, что корзина, находящаяся на рабочем столе, скрыта под окнами открытых приложений. Но, достаточно взять мышкой удаляемые файлы и задержать на мгновение курсор в свободном месте панели задач, и все окна сворнутся, открывая доступ к корзине и другим элементам Рабочего стола

Для того чтобы просмотреть свойства сразу нескольких дисков (например, чтобы определить, где больше места), откройте Мой компьютер, выделите несколько дисков, свойства которых вы хотите просмотреть, щелкните правой кнопкой мыши и выберите Свойства из контекстного меню. В появившемся окне каждая вкладка будет соответствовать одному диску.

Если вам нужно получить копию дискеты, есть очень простой способ, предоставляемый системой Windows. Вставьте диск в дисковод, откройте Мой компьютер, щелкните правой кнопкой на значке гибкого диска. Из контекстного меню выберите команду Копировать диск, в диалоговом окне нажмите кнопку Начать. После того, как Windows считает данные, система попросит другую. Вставьте другую дискету и нажмите кнопку OK

Иногда возникает проблема, когда вы пытаетесь удалить со своего винчестера какой-нибудь файл большого объема (например, фильм), а он не удаляется, хотя в данный момент файл не запущен, да и никакая программа его не использует. Попробуете в этом случае сделать следующее. Создайте пустой файл с тем же именем и расширением, что и у того, который необходимо удалить. После создания замените большой файл маленьким. А теперь просто удалите и его

Если у вас в сети на всех компьютерах стоят Win XP, и нужно послать сообщение какому-либо пользователю в локальной сети, то просто заходим в Пуск - Выполнить и набираем команду типа
net send <имя или ip адрес компьютера> <сообщение>.
Чтоб было понятнее, вот пример:
net send 192.168.0.1.2 Как дела?

Если в диалоге "Выключить компьютер" (Пуск-Выключение компьютера) нажать клавишу Shift, то кнопка "Ждущий режим" преобразуется в "Спящий режим"

Чтобы при выходе из спящего (hibernate) режима и режима ожидания (standby) Windows XP не требовала ввести пароль, нужно в апплете Электропитание в закладке "Дополнительно" убрать флажок "Запрашивать пароль при выходе из спящего режима"

Для Windows 9x существуют различные программы, позволяющие задавать прозрачный фон для значков на Рабочем столе. В Windows XP подобная надобность в программах отпала: щелкните на Рабочем столе правой кнопкой мыши и в появившемся контекстном меню снимите флажок "Упорядочить значки" - "Закрепить веб-элементы на Рабочем столе". Фон под названиями иконок станет прозрачным.

Для того, чтобы ускорить доступ к часто используемым папкам, можно один раз войти в них и в меню "Избранное" выбрать пункт "Добавить в избранное". После этого можно из любой папки нажав "Избранное" и выбрав название папки попасть в это папку

Можно ли отключить работу с zip-архивами как с папками в Windows Me/XP? Вообще-то работа с zip-архивами, как с обычными папками - это очень удобно, и есть, как мне кажется, только одна причина для отключения этой возможности - слабая и тормозящая машина. Отключается эта опция очень просто - набором в командной строке (или можно создать ярлык)
regsvr32 /u zipfldr.dll
Обратное включение - regsvr32 zipfldr.dll

Как автоматизировать вход в систему - без ввода логина и пароля? Пуск - Выполнить, вводим команду control userpasswords2 После открытия апплета, служащего для управления учетными записями пользователей, снимаем на вкладке Пользователи флажок напротив "Требовать ввод имени пользователя и пароля". После нажатия на кнопку ОК появится диалоговое окно "Автоматический вход в систему", где нужно будет указать имя пользователя и пароль.

Для особо забывчивых: создание дискеты для сброса пароля (Password Reset Disk)
С помощью этой дискеты можно будет зарегистрироваться на компьютере даже в том случае, если пароль забыт. Для создания Password Reset Disk следует выбрать Пуск-Панель управления-Учетные записи, щелкнуть по своей учетной записи. В появившемся окошке в левой колонке (где Родственные задачи) есть пункт Подсказка о пароле - после щелчка по нему запустится мастер создания "спасительной" дискеты. Эта дискета создается один раз - ее не нужно переделывать при каждой смене пароля, поэтому особое внимание следует обратить на порядок ее хранения: дискета должна храниться в укромном месте, потому что тот, кто найдет и воспользуется ей, сможет войти в систему под вашим именем

Если вдруг заголовок окна оказался за пределами вашего примера, вы не можете перетащить окно в другое место. Но вы можете воспользоваться горячими клавишами. Нажмите ALT+SPACE а затем нажмите Е (в русской версии) или M (в английской). Теперь вы может с помощью клавиш со стрелками перемещать окно в любое место

В Windows XP появился новый способ упорядочивания значков (если используется вид Значки): Вид -> Упорядочить значки -> по группам. После этого значки будут упорядочены по группам в алфавитном порядке

В Windows XP можно переименовать сразу несколько файлов. Для этого выделяем несколько файлов, щелкаем по любому из них правой кнопкой и переименовываем. Все выделенные файлы получат имя указанного файла с индивидуальным номером в скобках.

В Windows XP существует особый режим выключения компьютера - Спящий режим. Это режим "засыпания" операционной системы, при этом все содержимое оперативной памяти сохраняется на жестком диске, монитор и жесткие диски отключаются, после чего компьютер выключается. И при перезапуске компьютера состояние рабочего стола полностью восстанавливается, т.е. система полностью восстанавливает свое состояние, имевшееся на момент "засыпания". Проще говоря, на чем вы остановились, выключив компьютер его переводом в спящий режим, с того же самого места и сможете продолжить свою работу: все приложения будут работать точно также, как и до "спячки" - будто ее и не было вовсе.

Бывают ситуации, когда надо запустить на компьютере пользователя программу в скрытом виде (чтобы не было кнопки программы на панели задач и иконки в трее, а также чтобы не было видно окна программы), однако программистами в программе не предусмотрен такой режим запуска. Примеров можно привести массу, например, запуск какого-то монитора работы пользователя или клавиатурного шпиона... В этом случае можно воспользоваться средствами WSH для скрытого запуска таких программ. Вот пример JS-скрипта, запускающего в таком режиме обычный виндовый блокнот:

var WSHShell = WScript.CreateObject("WScript.Shell");
WSHShell.Run("notepad",0);

Второй параметр во второй строке, а именно - 0, указывает, что надо запустить файл в невидимом режиме. Создайте файл с расширением *.js и пропишите его в автозагрузку. Теперь работа вашей программы практически незаметна. Окно у нее невидимо, кнопки на панели задач нет, в диспетчере задач на вкладке "Приложения" она тоже не светится. Только в списке процессов возможно найти notepad.exe и снять его. Но если обозвать запускаемый файл по-заковыристей, например, nvidia32.exe или volsnd32.exe, то далеко не каждый пользователь найдет эту подделку. Да и потом, часто ли вы лазите в диспетчер задач с целью поиска "непонятных" процессов?

Как в Windows Millennium включить режим "command prompt only" и "Safe mode command prompt only"?
У Windows 98 при загрузке можно держать клавишу Ctrl, тогда появится меню с режимами загрузки, включая и два вышеперечисленных. У Millennium эти режимы отсутствуют.
Нужно заменить файл io.sys. Для этого возьмите чистую дискету и сохраните на ней "родной" io.sys с винчестера:
sys A:
Эту дискету используйте потом для восстановления оригинального io.sys. Создайте другую загрузочную дискету через меню Windows Setup в диалоге Установка/Удаление программ. После этого io.sys на винчестере замените тем, что предназначен для загрузки с дискеты (он расположен в каталоге С:\Windows\Command\EBD), загрузившись с созданной системной дискеты и сделав
sys C:
или такой командой из обычного режима:
sys C:\Windows\Command\EBD C:
После этой процедуры при загрузке будут обрабатываться файлы autoexec.bat, config.sys, msdos.sys, и появятся недостающие пункты в загрузочном меню.

В Windows, чтобы одним кликом открыть "Уровень записи" (а не десятью, как это предусмотрено разработчиками), достаточно создать ярлык с командой "c:\windows\sndvol32.exe -rec"

Удаление противного сообщения.
Если вы пользуйтесь опцией "Показывать как Веб-страницу" в Проводнике, то когда вы открываете в Проводнике папку Windows или System, то получаете предупреждение для новичков, что изменения в этих папках опасно для вашего здоровья :-)
Вам приходится нажимать на кнопку "Показать файлы". Чтобы убрать это надоедливое сообщение, сделайте следующее:
- Найдите файлы folder.htt в папках Windows и System. Переименуйте их в folder.out (на всякий случай).
- Откройте папку Windows в Проводнике.
Выберите меню Вид - Настроить вид папки.
Появится мастер настройки папки. Дважды нажмите кнопку Далее.
Откроется Блокнот с содержимым файла folder.htt.
Закройте Блокнот. Нажмите кнопку Готово в мастере настройки. Все!
Аналогично проделайте с папкой System.

Восстановление ярлыка "Свернуть все окна".
Если вы случайно удалили значок "Свернуть все окна" на панели быстрого запуска, есть возможность востановить его. Для этого откройте папку C:\WINDOWS\Application Data\Microsoft\Internet Explorer\Quick Launch и создайте там текстовой файл с таким содержанием:
[Shell]
Command=2
IconFile=explorer.exe,3
[Taskbar]
Command=ToggleDesktop
Сохраните получившийся файл как "Свернуть все окна.SCF". На панели быстрого запуска должен появиться новый значок

Как отредактировать меню "SendTo" в Windows XP? Так же, как и в Windows 9x, только папка на сей раз будет немного другая: С:\Documents and Settings\Имя пользователя\SendTo\.

Встречал такие программы, которые переводят текст в рисунок для того, чтобы не подбирать кодировки, да они еще и триальные. Все делается очень просто: пишем текст в блокноте, копируем и вставляем в подготовленное для текста место в программе Paint, сохраняем рисунком.

Избавление от лого виндов при загрузке:
В файле MSDOS.SYS в раздел Options добавить строку Logo=0
Для разработчиков программ - компьютер иногда очень часто вешается и приходится перезагружаться по 10 раз на день и столько же раз видеть работу ScanDisk, нужно ли это? Сомнительно! В 99% случаев нарушения однотипны и не опасны - или неправильно прописан размер свободного места или потерянные кластеры. Обычно достаточно сканировать диск раз в несколько дней, а то и недель. Выключить сканирование можно поставив в файле MSDOS.SYS в раздел Options строку Autoscan=0, а Scandisk прописать в расписание, чтоб запускался по ночам или в другое неиспользуемое время.

Чтобы изменить заставку при загрузке Windows, создайте файл logo.sys в формате bmp с размерами 320х400 256 цветов, и поместите его в корневой каталог диска, где установлен Windows. Если вы хотите отключить появление картинки при загрузке, добавте в раздел [Options] файла msdos.sys строку Logo=0.
В каталоге Windows есть два файла: logow.sys, logos.sys. В них содержатся картинки "Завершение работы Windows" и "Теперь питание можно отключить". Формат их аналогичен файлу logo.sys. Вы можете заменить их на свои картинки, или вообще удалить, тогда при выключении компьютера ничего не будет отображаться.

Если у вас Windows 2000, то есть возможность ускорить ее загрузку. Попробуйте отказаться от традиционного "shutdown" и выбрать "hibernate" в меню выключения. Грузится будет в два раза быстрее, правда, при это все содержимое памяти сохранится и после включения музыка как ни в чем не бывало продолжит играть.
Включить эту опцию можно в настройках "Power management" панели управления.

Можно несколько увеличить скорость загрузки Windows, если отключить определение подключения дисковода при загрузке. Для этого щелкните правой кнопкой мыши по иконке "Мой компьютер", выберите "Свойства", перейдите на вкладку "Быстродействие" и нажмите кнопку "Файловая система". Там надо выбрать вкладку "Гибкие диски" и снять галочку с опции "При запуске компьютера определять, подключен ли дисковод".

Если Вы хотите защитить свой компьютер от сослуживцев, то впишите в autoexec.bat что-то вроде:

:loop
cls
echo Error Loading Windows 95.
pause
goto loop

При этом машина будет выдавать сообщение об ошибке и просить нажать на кнопочку, после нажатия выскочит то же самое сообщение... Вы сами сможете прервать этот цикл, нажав +. Как правило, даже такой простой меры достаточно, чтобы отсечь большинство пользователей.

Чтобы временно отключить запуск экранной заставки (например, во время дефрагментации диска), нажмите кнопку Пуск, чтобы открыть меню. Пока меню развернуто, заставка не запустится.

Как защититься от администратора в Windows 2000?
Одно из преимуществ NTFS, состоит в том, что можно создать разграничение доступа к файлам и каталогам. Пользователь не сможет посмотреть папку Мои документы другого пользователя, если этот пользователь не является администратором. Как же защититься в таком случае? Запретить доступ к своим данным нельзя, а вот узнать, копался ли администратор по личным папкам и документам можно.
Допустим, вы решили закрыть папку для всех и разрешить доступ только себе. Щелкните правой кнопкой мыши по файлу/папке, выберите из меню команду Свойства, на вкладке Безопасность удалите всех, кроме себя.
Теперь система не позволит администратору посмотреть этот файл/папку. Так как он администратор, ему не составит особого труда проделать то же самое что и вы и добавить для себя разрешение на полный доступ к этому файлу/папке, а затем удалить себя, дабы никто не узнал. Но текущим владельцем этого файла/папки на века теперь станет администратор, в чем вы сможете убедиться, нажав на вкладке Безопасность кнопку Дополнительно, в новом диалоговом окне перейти на вкладку Владелец и посмотреть на поле "Текущий владелец для этого элемента". До этого им были вы.

В случае возникновения системной ошибки диагностическое сообщение о ней выводится в текстовом режиме белым цветом на синем фоне, так называемый Синий Экран Смерти - Blue Screen of Death (BSOD). При желании этот экран можно "перекрасить", скажем, в красный цвет с белыми буквами. Для этого нужно добавить в файле SYSTEM.INI в секции [386Enh] две строки MessageBackColor=4 и MessageTextColor=7, где цифры задают стандартные ASCII-цвета.
После перезагрузки они вступят в силу, что можно проверить, не дожидаясь ошибки, - вставьте чистый диск в 3,5" дисковод, найдите какой-нибудь файл длиной около 1 МБ и в окне MS DOS выдайте команду его копирования на дискету. Когда файл начнет записываться, извлеките дискету (прямо во время записи). Через несколько секунд Windows выдаст сообщение о невозможности записи файла, расцвеченное новыми цветами.
Замечание:
Таким способом можно и повредить дисковод. А вот с CD такого нет! Нужно просто задать команду скопировать что-нибудь с CD-ROMa и нажать кнопку выброса диска. Результат будет тот же.

Если в Windows создать пустой файл с расширением *.fnd , то при запуске этого файла откроется окно "Найти: Все файлы"

В Виндах можно "ужать-раздвинуть" все ячейки таблички по их содержимому нажатием "CTRL"+"+". Например, зайти в Винде в любой лог (не обязательно лог - любая таблица), если там все записи в своих ячейках умещаются, то изменить их размер так, чтобы не умещались (ну это для примера, конечно :), а потом нажать "Ctrl"+"Grey+".

Если требуется открыть сразу несколько файлов в одной папке, следует выделить одновременно их значки (например, щёлкнув по первому и последнему при нажатой клавише SHIFT), а затем нажать ENTER.

Если дважды щелкнуть по активной панели окна (синяя полоска вверху окна) то программа переключится из оконного в полноэкранный режим и наоборот.

Если во время запуска Borland C++ Builder нажать и удерживать клавиши Shift+Ctrl, будет очень интересный эффект. Какой не буду рассказывать, чтобы не портить эффект - посмотрите сами :).

Создаём текстовый файл (в "Мои документы"), как-нибуть "обзываем" (у меня, например - @@@). Далее создаём ярлык этого файла в Windows\Application Data\Microsoft\Internet Explorer\Quick Launch. И теперь всегда под рукой блокнотик. Нужный адрес - скопировал, текст - без проблем. Вобщем - весьма удобно.

Бывают ситуации, когда надо представить какой-то каталог в качестве отдельного логического диска (например, при большой вложенности до него очень долго добираться, а пользоваться им приходится часто, или программы настроены на работу с определенного диска и т.п.). В этой ситуации на помощь придет команда:
subst d: c:\kakoyto\dalekiy\katalog
Эта команда создаст виртуальный диск D:, который ничем не будет отличаться от логического. В качестве такого диска будет использоваться каталог, указанный вторым параметром команды. Отменить выделение виртуального диска можно командой
subst d: /D
Если вы хотите, чтобы виртуальный диск у вас был постоянно, просто добавьте эту команду в autoexec.bat.
Примечание: В Windows 2000/ХР файл AUTOEXEC.BAT не обрабатывается, лучше написать файл BAT и прописать его в реестре в автозагрузку:
1. Создаем файл, например wertdisk.bat, в теле пишем subst d: c:\kakoyto\dalekiy\katalog
2. Создаем строковый параметр, например Baton, в ключе [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run] и указываем в этом строковом параметре путь до файла wertdisk.bat, например c:\katalog\wertdisk.bat. Или создать к этому файлу BAT ярлык и поместить его в папку Автозагрузка

Иногда, некоторые старые программы не хотят устанавливаться, указывая нехватку места на винте, несмотря на то что места более чем достаточно (например Paradox 7), дело в том что инсталлятор просто не может прочитать число байт более 2 миллиардов. Для установки таких программ, потратьте свободное место на винте (копируя какие-нибудь файлы), чтоб осталось меньше 2G, установите программу, затем удалите ненужные файлы, восстановив свободное место на диске.

ОЧЕНЬ не советую уменьшать размер раздела (partition), несущего сжатые диски Drivespace. Потеря данных - гарантирована! (1%-5% кластеров по всему диску). Увеличивать - можно.
P.S. Если ошибка уже сделана - часть данных (9% или 99%) можно спасти Diskeditor-ом (запись обьекта (битого файла) в файл на другом диске).

Чтобы в Photoshop'е вывести диалог открытия файла вовсе не обязательно лезть в меню "Файл" или нажимать "горячие клавиши". Достаточно дважды щелкнуть по свободной (серой) области в окне программы.

Винт любого размера лучше разделить на несколько маленьких. Так на основной раздел можно оставить гига три-четыре, на дополнительные остальное. Зачем? Оптимизация диска идёт быстрее, скандиск летит быстрее после сбоя, переносить систему значительно легче, дерево каталогов получается меньше - соответственно на поиск файлов винда тратит меньше времени.
Рекомендую на c: только ставить программы, на d: держать те проги, которые идут без установки и игры, на остальных - по желанию...

Переразбивку жесткого диска без потери данных достаточно легко сделать с помощью Partition Magic. Я им давно уже пользуюсь и ни разу еще, слава Богу, проблем не было. Единственная настоятельная рекомендация - за один раз только одно изменение, затем перезагрузка.

Расширения ненужных файлов
*.tmp; *.~mp; *.gid; *.fts; *.chk; *.00*; *.---; *.$$$; *.*$; ~*.*; *.~*; *.??_; *.??~; *.^*; *.syd; *.prv; *.old; *.bak; mscreate.dir
Выбрав эти файлы в окне поиска, например Windows Commander, вы можете удалить их, тем самым освободив диск на несколько мегабайт. Но есть одна неприятность:
У многих пользователей жесткий диск не разбит на разделы, и дистрибутивы хранятся вместе с системными файлами, т.е. на одном диске с C:\WINDOWS\. В таком случае Вы можете потерять важные файлы. Поэтому, всегда разбивайте жесткий диск минимум на два раздела, и храните дистрибутивы на втором, не на загрузочном диске, в отдельной папке.

Если есть желание, чтобы все временные (tmp) файлы удалялись после запуска компьютера (а они не нужны), следует в файл autoexec.bat ввести следующие строки:
set tmp=c:\tmp
set temp=c:\tmp
set pktmp=c:\tmp
del c:\tmp\*.tmp > nul

Еще один способ удалять все временные (tmp) файлы после запуска компьютера (а они не нужны). Следует в файл autoexec.bat добавить следующие строки:
@ECHO Cleaning of a temporary folder...
DELTREE /Y C:\TEMP > NUL
MD C:\TEMP
SET TMP=C:\TEMP
SET TEMP=C:\TEMP
SET PKTMP=C:\TEMP
@ECHO Temporary folder is clean


Установка Windows

В отличие от W2k, где всё необходимое шло вместе с дистрибутивом, для создания загрузочных дисков XP вам придётся скачать пакет из http://support.microsoft.com/support/kb/articles/q310/9/94.asp?ID=310994
Для создания комплекта загрузочных дискет вам понадобится 6 флоппи-дисков. При загрузке с них вы окажитесь в той же программе установки, что и при загрузке с компакт-диска с XP, так что если у вас есть возможность грузиться с такого диска, эти дискеты вам не нужны.

Где хранится код активации Windows XP? Как известно, лицензионная Windows XP при переустановке системы требует повторной активации. Чтобы этого избежать, достаточно перед переустановкой системы скопировать файл wpa.dbl, расположенный в папке windows\ System32, например, на дискету - именно в этом файле хранится код активации. После переустановки системы, естественно, нужно будет заменить файл wpa.dbl на тот, что записали на дискету.

При установке Win2k если идти по загрузке из-под "чистого" DOS, то предварительное копирование файлов может занять до 1,5 часов. Все дело здесь в том, что не установлено предварительное кэширование дисков. Кэширование выполняется командой smartdrv (находится в каталоге Windows на любой машине, на которой установлены Windows 98). После этого предварительное копирование файлов занимает около 20 - 30 минут.

Если при установке новой версии Windows поверх старой вам заявляют, что не хватает места на диске С:, попробуйте задать в командной строке программы инсталляции ключ /id, который отключает проверку доступного на диске места: setup.exe /id.

Если программа установки Windows98 останавливается на процессе проверки дисков, то можно пропустить эту проверку, запустив программу установки в следующем виде:
setup /is /iq
Особенно часто такое зависание происходит при установке на диски более 2 ГБ.

Некоторые программы в Windows 2000 отказываются устанавливаться без видимой на то причины (возможно эта проблема есть и в ХР). Это может происходить из-за того, что пользователь, под которым производится установка, содержит в своем имени русские буквы. Просто создайте нового пользователя с правами администратора, в имени которого будут только латинские буквы, и попробуйте запустить установку под ним.
Дополнение к совету: Тут дело не совсем в имени - дело в том, что по умолчанию каталоги временных файлов - TEMP и TMP, а именно в ТЕМР установщик как раз временные файлы и копирует - располагаются в папке Documents and Settings/<Имя пользователя>/TEMP, и вот как раз русскую часть имени этой папки установщики и не понимают. Еще возможен вариант еще более старого :))) установщика, не понимающего и длинные имена файлов - тогда и переименование не поможет. Проблема может быть решена проще: щелкнуть правой клавишей на "Мой компьютер" - Свойства - Дополнительно - Переменные среды. Там в верхнем окне - переменные среды для <Имя пользователя> как раз эти пути и задаются. Проще всего создать специальную папочку типа TEMP недалеко от корня диска, чтобы если что далеко не лазить, и прописать в качестве этих переменных среды ее. После этого все становится нормально (возможно потребуется перезагрузка, чтобы изменения вступили в силу - точно сказать не могу)

Возникающие проблемы часто пытаются решить переустановкой Windows. При переустановке Windows без предварительного удаления её каталогов проблемы, однако, могут сохраняться, так как неприятности могут быть связаны с тем, что что-то неверно записалось в реестре, а при переустановке "поверх" в реестре почти всё остаётся по-старому. Поэтому обычно эффективна только переустановка с предварительным удалением каталогов Windows и Program Files. Но после этого приходится инсталлировать и настраивать почти все программы по новой. Чтобы не тратить на это время и обеспечить возможность анализа причин неприятностей, в Windows периодически сохраняйте в каталоге С:\WINDOWS\SYSBCKUP\ (этот каталог скрытый) копии файлов реестра system.dat и user.dat (а также заодно system.ini и win.ini). В Windows 98 это автоматически ежедневно при первом запуске системы делает утилита SCANREG, которая также занимается чисткой реестра. Эта утилита сжимает вышеуказанные четыре файла и сохраняет их в каталоге (С:\WINDOWS\SYSBCKUP\) в cab-архиве под именем rbxxx.cab, где xxx - номер резервной копии. По умолчанию сохраняются 5 последовательных копий, а затем каждая новая замещает самую старую. Можно заставить SCANREG сохранять до 99 резервных копий, присвоив нужное число параметру MaxBackupCopies в файле scanreg.ini. Также можно дополнительно сохранять в этих cab-архивах копии других файлов (например autoexec.bat и config.sys), указав в параметре Files их полные имена с путём.
Для восстановления реестра нужно перезапустится в DOS и в командной строке набрать scanreg /restore далее выберите архив и дату сохраненного реестра и нажмите восстановить.


Меню кнопки "Пуск"

Сине-черная полоска кнопки Пуск.
Если вы обнаружили, что в меню кнопки Пуск левая сине-черная полоска, на которой раньше было написано "Windows Millenium..." стала абсолютно черной, то знайте, что эта надпись отображается, только если в меню "Пуск" присутствует 8 и более иконок. Просто верните назад отображение тех значков, которые вы убрали, использовав диалог свойств меню "Пуск".

Когда вы открываете меню Пуск в Windows Me/2000, список может быть очень коротким и всюду около пунктов будут маленькие стрелочки. Если вы щелкните по стрелочкам - раскроется полное меню. Вы можете выключить эту чудо особенность Microsoft, нажимая кнопку Пуск и раскрывая подменю Настройка. Выберите команду Панель задач и меню "Пуск" и перейдите на вкладку Общие. Затем снимите галочку "Использовать сокращенные меню". Теперь меню и любое подменю будут полностью раскрыты. Эта новшество введено в Windows Me/2000/XP, в более ранних версиях этого нет.

Хотите видеть панель управления в виде выпадающего меню в главном меню? Нет ничего проще! Сделайте следующее: запустите RegEdit, в разделе HKEY_CLASSES_ROOT\CLSID поищите строку "Панель управления" (без кавычек ;). Вы увидете что строка эта будет находится в разделе с именем типа {21EC2020-3AEA-1069-A2DD-08002B30309D}. Скопируйте название этого раздела в буфер обмена. Теперь нажмите правую кнопку мыши на главном меню и выберите "Открыть". В окне создайте папку с именем вида "Панель управления.{21EC2020-3AEA-1069-A2DD-08002B30309D}". Обратите внимание что сохранненое в буфере название раздела будет являться для этой папки расширением. Все - теперь у вас в главном меню есть пунктик "Панель управления" со всем соответствующим содержимым. Пользуйтесь ;)

Если перетащить ярлык на кнопку "Пуск", то он добавится в меню над пунктом "Программы". Однако, сильно увлекаться не стоит, т.к. большое количество ярлыков приведет к существенному замедлению появления этого меню на экран (так, я наблюдал на ноутбуке Р2-350 почти секундную задержку при наличии около 10 дополнительных ярлыков в меню).

Если нажать кнопку "Пуск", выбрать пункт "Выполнить" (Run) и напечатать в строке точку, то откроется папка "Рабочий стол" (desktop). А если напечатать две точки, то откроется папка Windows.


Проводник

Изменение фона для проводника.
Если вы используете в Проводнике опцию "Как веб-страница", то найдите в папке Windows/Web файл wvleft.bmp, в котором содержится рисунок облачков, появляющихся в левом верхнем углу проводника и замените его на свой

Ключи командной строки Проводника:

  • /e - Вид Проводника по умолчанию (двухпанельное), иначе выводится как однопанельное (как Папка).
  • /e, object - Открывается Проводник с видом по умолчанию и с фокусом на заданной папке (Explorer /e,C:\Windows)
  • /n - Открытие однопанельного нового окна на диске, на котором установлена система (C:\). Иначе информация выводится в существующем окне Проводника, если оно открыто.
  • /root, object - Указывает на то, что корнем будет object - это дисковод (сетевой или локальный) или папка. Иначе корнем считается Рабочий стол. (Explorer /root, C:\Windows\Cursors)
  • /select, object - Указывает на необходимость открытия Родительской папки объекта object и выделит object (Explorer /select, C:\Windows\Cursors\banana.ani).

По умолчанию Проводник открывается на диске C:, но вы можете изменить это поведение, заставляя его, к примеру, открывать при запуске папку D:\MyDownload. Для этого, найдите ярлык к Проводнику, щелкните правой кнопкой и выберите свойства. Выберите вкладку Ярлык. Отредактируйте строчку Объект - C:\WINDOWS\EXPLORER.EXE /n,/e,D:\MyDownload.

Если создать ярлык и указать в качестве командной строки "C:\WINDOWS\EXPLORER.EXE /ROOT," (без кавычек, но с запятой в конце), то этот ярлык будет открывать рабочий стол (desktop). Причем, в проводнике будут показаны и системные иконки (сетевое окружение, outlook и т.д.).

Иногда, когда не установлен параметр перезагрузки при system crashes можно вывести систему на чистую воду - в основном возникают ошибки в explorer.exe - убиваем его, или он уже убит, то жмём New task - explorer.exe - всё в порядке!

Если в проводнике посмотреть на аудио CD, то Вы увидите, что дорожки представлены как файлы. Вы можете создать ярлык к такому файлу, например, перетащив его на рабочий стол, что даст Вам возможность играть любимую песню просто щелкнув по этому ярлыку.


Панель задач

Если у вас открыто несколько программ, вы вероятно закрываете их один за другим. Но есть более удобный способ. Нажмите и удерживайте клавишу [Ctrl] и кликайте на на тех кнопках на панели задач, чьи программы вы хотите закрыть (вы заметите, что выбранные кнопки будут вдавлены). Теперь можете кликнуть правой кнопкой на одной из этих выбранных кнопок и выбрать команду Закрыть (или любую другую). Попробуйте, вам понравится.

Проще и эффективнее можно организовать каскадное меню в панели задач, щёлкнув по ней правой кнопкой мыши и поставив галочку в контекстном меню: Панели инструментов - Рабочий стол. После чего необходимо мышью сузить полученную панель до того, что на ней не останется ничего, кроме слова "Рабочий стол" и маленькой двойной стрелочки в правом углу. Именно после щелчка по этой стрелочке открывается удобнейшее каскадное меню с содержимым ВСЕГО, что находится на Рабочем столе (Все папки, Мой компьютер, Сетевое окружение, Корзина и пр.).
Попробуйте один раз - оставите навсегда.

Если Вы хотите перетащить какой-нибудь объект (например файл) в окно программы, которая минимизирована или закрыта другим окном, то просто перетащите этот объект на кнопку программы на таскбаре и задержите на секунду...

Очень удобно разместить панель задач (TaskBar) не внизу экрана, как это сделано по умолчанию, а вдоль его левой стороны. Это дает несколько плюсов: кнопки программ на панели будут постоянного размера, даже если у вас открыто одновременно десяток задач; иконки в трее и панели быстрого запуска располагаются в несколько рядов, освобождая место под кнопки программ; приходится меньше бегать мышкой при перемещении в меню кнопки "Пуск". В свойствах панели задач лучше указать "Автоматически убирать с экрана", чтобы не занимать лишнее место на Рабочем столе. Размещать панель справа неудобно, т.к. там находятся кнопки управления размерами окон программ и полосы вертикальной прокрутки, так что при неосторожном движении панель может выскочить из-за края экрана и перекрыть те элементы окна до которых вы хотели добраться.

Вам когда-нибудь приходилось открывать одни и те же папки много раз в день? А если одна из папок находится, например, в C:\Program Files\Borland\Delphi5\Projects\Ball, то каждый раз вам приходилось открывать сначала 'Мой компьютер', потом папку Program Files, потом Borland и т.д. Правда, неудобно? Так вот суть совета состоит в создании специальной панели на панели задач Windows'98, где и находятся ярлыки к наиболее часто используемым папкам.
Что делать?
Создаёте папку где хотите, но я советую в папке Windows, и называете её так чтобы было потом понятней, например 'сюда', или 'ссылки', или 'links'.
Теперь у вас есть папка, где будут хранится ярлыки к наиболее часто используемым папкам.
Затем создаете ярлык к новосозданной папке, украшаете его (переименовываете, меняете иконку) и помещаете в папку C:\Windows\SendTo.
Кликаете правой кнопкой мыши на пустом месте панели задач и выбираете пункт 'Панели инструментов' и в подменю пункт 'Создать панель инструментов...'
В открывшемся окошке выбираете ту папку, которую вы создали.
Всё! Панель готова!


Системные иконки

Давайте добавим папку "Принтеры" в меню Пуск, причем все значки в ней превратятся в пункты подменю. Это поможет облегчить и ускорить доступ к этим элементам. Для этого надо зайти в настройку Панели задач и меню "Пуск", перейти на вкладку "Настройка меню" и выбрать кнопку "Дополнительно". В правой части открывшегося окна надо создать папку Принтеры.{2227A280-3AEA-1069-A2DE-08002B30309D} где значение до точки - имя папки, а после точки - ее расширение (фигурные скобки нужны обязательно!).
Вот еще имена для стандартных элементов:
для папки Удаленный доступ к сети - Имя.{992CFFA0-F557-101A-88EC-00DD010CCC48}
для Корзины - Имя.{645FF040-5081-101B-9F08-00AA002F954E}
для папки Подписка - Имя.{F5175861-2688-11d0-9C5E-00AA00A45957}
для папки Шрифты - Имя.{BD84B380-8CA2-1069-AB1D-08000948F534}
для папки History - Имя.{FF393560-C2A7-11CF-BFF4-444553540000}
для папки Назначенные задания: Name.{D6277990-4C6A-11CF-8D87-00AA0060F5BF}
для папки Web Folders: Name.{BDEADF00-C265-11d0-BCED-00A0C90AB50F}
Причем имя может быть любым. Такие папки можно добавить в любой каталог на жестком диске.

Стандартные значки Windows 9x. В разделе реестра [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Current Version\explorer\Shell Icons] содержится множество строковых параметров с именем в виде числа. Каждый из них отвечает за значок какого-либо объекта:
0 Стандартный значок
1 Исполняемый файл
2 Избранное
3 Папка
4 Открытая папка
5 Дискета 5.25"
6 Дискета 3.5"
8 Жесткий диск
9 Сетевой диск
10 Недоступный сетевой диск
11 CD-ROM
12 Ram Drive
13 Вся сеть
15 Мой компьютер
16 Принтер
17 Сетевое окружение
18 Файл с конфигурациями
19 Программы
20 Документы
21 Настройка
22 Поиск
23 Справка
24 Выполнить
27 Завершение работы
28 Зашарить (ну не знаю я, как это по-русски сказать)
29 Ярлык
31 Пустая корзина
32 Полная корзина
33 Удаленный доступ к сети
34 Рабочий стол
35 Панель управления
36 Программы
37 Принтеры
38 Шрифты
40 Музыкальный CD
Установите значением параметра путь к значку (если значок хранится в библиотеке, то после пути к ней, через запятую, нужно указать номер значка, начиная с нуля), и он изменится.


Ярлыки

У вас, вероятно, есть две-три программы, которые вы запускаете ежедневно, а то и по много раз в день. И, скорее всего, вы вынесли ярлыки этих программ в наиболее удобное место на "Рабочем столе", чтобы запускать их как можно быстрее. Можно еще больше ускорить запуск этих программ, если задать "горячие" клавиши для их вызова. Для этого щелкните правой кнопкой мыши по ярлыку нужной программы, выбирите пункт "Свойства" и на вкладке "Ярлык" установите курсор мыши в поле "Быстрый вызов". Затем нажмите комбинацию клавишь для вызова этой программы (Ctrl+Alt+буква, Ctrl+Shift+буква, Alt+Shift+буква или Ctrl+Alt+Shift+буква). Привыкнуть к такому способу открытия программ очень просто, даже удивляешься, как раньше обходился без этого.

Для многих команд Windows можно сделать ярлыки. Сделать это очень просто: в контекстном меню выберите Создать -> Ярлык и укажите необходимую командную строку, например:
rundll32 shell32,SHExitWindowsEx -1 Перегрузить Explorer.
rundll32 shell32,Control_RunDLL Открыть "Панель управления".
Полный список команд можете посмотреть здесь

Если вам надо постоянно обращаться к какому-то элементу Панели управления, то можно создать ярлык на "Рабочем столе" с такой командной строкой: "CONTROL.EXE desk.cpl,,3". Desk.cpl указывает вызываемую функцию "Панели управления". Например, appwiz.cpl откроет окно "Установка и удаление программ", а цифра следующая после двух запятых - номер нужной вкладки, начиная с нуля.


Настройка оболочки

В папке Windows\Web можно найти несколько интересных файлов. В этой папке надодится скрытый файл webview.css, в котором определены настройки стилей отображения тех папок, для которых выбран вид "Как web-страница". Изменяя прописанные в нем классы, вы можете менять свойства шрифта, фона заголовок, списка файлов. Например, прописав в body вместо color: windowtext другой цвет, скажем, green, вы увидите зеленый текст в левой части странички

Убрать значки с "Рабочего стола" и создать ОЧЕНЬ быструю панель можно нажав на "трэе" (там, где часы) правую кнопку мыши. В меню выбрать "Панели инструментов" - поставить галочку "Рабочий стол" (если там такового нет - нажать "создать" и там выбрать "Рабочий стол"). При этом слева от трэя появится оная перемещаемая панелька со стрелкой, разворачивающей всё содержимое "Стола". После этого зайти в свойства экрана, вкладка "Эффекты" и там установить галку "Прятать содержимое стола, если...".
Всё! Вся фишка в том, что:
1. не захламляются ваши обои и
2. (самое главное!) через эту менюшку можно практически мгновенно добраться до ЛЮБОЙ точки вашего компа НЕ ЗАПУСКАЯ ПРИ ЭТОМ ВСЯКИХ "ПРОВОДНИКОВ", "КОММАНДЕРОВ" и т.д., (заодно и ресурсы экономятся!) Попробуйте, не пожалеете!
З.Ы. Для 98 Выньды. Для остальных - не знаю, есть ли там такое... ;)

Для того, чтобы вставить любое слово рядом с часами нужно сделать следующее:
1. Зайти на "Панель управления", затем "Язык и стандарты"
2. Перейти на вкладку "Время"
3. В поле "Формат времени" измените формат на "ЧЧ:мм:сс оо" (оо набирать русскими), в полях обозначения времени до и после полудня введите ваше слово.

Вы пользуетесь пунктом контекстного (всплывающего) меню файла или папки "Отправить"? Если нет, то вы много теряете! Когда вы кликаете правой кнопкой на файле или папке выбираете пункт "Отправить" и там выбираете, куда хотите отправить, то выбранный вами файл копируется (перемещается) в ту папку, которую вы выбрали. Здорово, правда?
Так вот ярлычки для пунктов назначения (папок) хранятся в X:\%windir%\SendTo, т.е. если у вас Windows установлена на диске C, то путь к папке SendTo будет выглядеть так: C:\windows\SendTo. Очень удобно! Так вот суть этого совета:
1) Вы создаёте ярлык для папки SendTo.
2) Извращаетесь над ним (меняете иконку, переименовываете).
3) Копируете этот ярлык в папку SendTo.
Теперь, когда вы много всего копируете(перемещаете) в определённую папку, то создаёте для неё ярлык и отправляете в Отправить! Очень удобно! Сам испытал!

По сути не совет, а прикол для тех кому понравился вариант использования функции "Послать".
Если вы работаете в Инете, то слово "Послать" у вас ассоциируется с отправкой письма, а если вы к тому же и гражданин бывшего СССР, то и ещё кое с чем 8). Берём, создаём ярлык ссылающийся на корзину и переименовываем его в "На...*" (зависит только от вашей фантазии). Потом переносим этот ярлык в папку ..windows/SendTo/


Контекстное меню файлов и папок

Когда вы запускаете файл, ассоциированный с каким-то приложением в Windows, то файл открывается именно в этом приложении. А как быть, если вам надо открыть этот файл в другом приложении? С WinNT/2000/XP все понятно: там в контекстном меню файлов всегда присутствует пункт "Открыть с помощью...". В Win9х этого пункта изначально нет, но если выделить нужный файл и, удерживая Shift, щелкнуть правой кнопкой мыши по нему, то в контекстном меню появится дополнительный пункт "Открыть с помощью...". Таким образом удобно как переассоциировать открытие файлов на другое приложение (без копания в реестре и разных диалогах), так и использовать это для какого-то конкретного случая.

Как связать несколько приложений с одним расширением файла.
Например, документ в формате Microsoft Word for Windows (расширение .doc) можно открывать как с помощью MS Word, так и с WordPad. Для этого:
1. Откройте окно "Мой компьютер".
2. В меню "Вид" выберите пункт "Свойства папки".
3. Выберите закладку "Типы файлов".
4. В списке "Зарегистрированные типы файлов" выберите "Документ Microsoft Word".
5. Нажмите на кнопку "Изменить".
6. Нажмите на кнопку "Добавить".
7. В строке "Действие" введите:
Открыть в WordPad
8. В строке "Приложение, исполняющее действие" введите:
"{path}\wordpad.exe" "%1"
где {path} - полный путь к файлу Wordpad.exe. В этой строке кавычки обязательны.
9. Нажмите кнопку "OK".
Если после этого вы дважды щёлкните левой кнопкой мыши на файле с расширением .doc, то документ откроется программой Microsoft Word. Если вы щёлкните правой кнопкой мыши на файле такого типа, то из появившегося меню сможете выбрать пункт "Открыть в WordPad".

Запуск программы из меню корзины
Для добавления программы в меню корзины(щелкните правой кнопкой мыши по иконке корзины) нужно сделать следующие:
- Откройте ветвь реестра "HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\Shell"
- Создайте в ней раздел с вашем именем
- В новом разделе создайте еще один с названием "Command"
- В параметре по умолчанию задайте путь к файлу который вы хотите открыть.


Иконки

Системные иконки находятся в файлах типа *.ICO (одна иконка, возможно в нескольких режимах), *.EXE (приложение), *.DLL (динамическая библиотека). Для указания иконки в приложении или в библиотеке нужно в пути после имени файла через запятую указать номер значка в файле. Пример: explorer.exe,0.
Где находятся иконки???
Иконки можно найти во многих системных файлах:
\Windows\System\Pifmgr.dll - мастер создания ярлыков
\Windows\System\Shell32.dll - оформление системы
\Windows\System\User.exe - иконки системных сообщений
\Windows\System\Cool.dll - иконки пакета MS Plus!
\Windows\Progman.exe - диспетчер программ
\Windows\Moricons.dll
\Windows\*.CPL - компоненты Панели Управления.

Переименовав .bmp файл в .ico, Вы получите "полнофункциональную" иконку. Только размер файла не изменится... Обратное "преобразование" тоже работает. Также можно переименовывать эти файлы в .cur и изменять вид курсора.


Ускорение ОС

При открытии папки "Мой компьютер", если в приводе CDROM имеется диск, он начинает раскручиваться и открытие папки существенно замедляется. Чтобы заставить систему раскручивать диск только когда к нему обращаешься непосредственно, надо создать DWORD параметр Autorun со значением 0 в разделе HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\CDRom

Ускорить запуск Windows XP, и освободить память можно путем отключения системных Служб. Отключить их можно разными путями: в командную строку ввести команду services.msc или в меню "Администрирование" в разделе "Службы" выбрать свойство нужной службы. Второй путь более рационален, т.к. вы не забудете, что отключали и в любое время можете восстановить - "Настройка системы" (msconfig.exe). При отключении служб нужно быть аккуратным, т.к. отключение чего-то лишнего может привести к нестабильной работе системы, поэтому, перед отключении нужно экспортировать ветвь служб реестра (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Serviсes), и сохранить на диске, чтобы в любой момент, можно было восстановить. Еще один совет, перед отключением какой-либо службы, посмотрите "Зависимости" в свойстве этой службы, какие компоненты зависят от отключаемой вами службы.

Windows XP создает и поддерживает индекс всех файлов на дисках для того, чтобы ускорять их поиск. Обратная сторона медали - замедляется выполнение остальных команд типа открыть, закрыть и т.п. Мне лично компромисс показался неудачным:
- Открываем My Computer.
- Из контекстного меню иконки жесткого диска выбираем Properties.
- Снимаем галочку на опции Allow indexing service to index this disk for faster searches.
- В появившемся окне выбираем опцию Apply to all folders and subfolders.
- Повторяем процедуру для всех оставшихся жестких дисков компьютера.

Ускорение работы Windows 9x
- Не пользуйтесь Wallpapers: чем больше размер картинки и количество цветов в ней - тем сильней ее использование в качестве wallpaper замедлит работу компьютера.
- Не используйте больше цветов, чем вам надо. Если вы не занимаетесь профессионально графикой - то 256 цветов вполне достаточно. (Хотя конечно все зависит от того, какой Video card у вас установлен и сколько Mb видеопамяти у вас есть).
- Не используйте анимационные курсоры. Они, конечно, влияют не так, как wallpaper, но все же отказ от них может немного ускорить ваш компьютер.
- Установите размер кэша для CD-ROMа в соответствии с вашими потребностями. Если вы не пользуетесь CD-ROMом для просмотра видеофильмов и редко запускаете тяжелые мультимедийные игры - то 256 Кб. кэша хватит выше крыши. Чтобы изменить настройки кэша для CDROMа - откройте My computer/Control Panel/System, выберите закладку Perfomance и нажмите на кнопку File system. Там выберите закладку CD-ROM и установите желаемый размер кэша.
- Старайтесь не использовать звуковые эффекты, которые поставляются вместе с Windows.
- Внимательно изучите autoexec.bat, config.sys, win.ini и system.ini. Из autoexec.bat можете удалить драйвера мышки, CD-ROMa, Soundblastera, smartdrive (windows все равно использует свои драйвера и свое дисковое кэширование). Из config.sys можно удалить строчки с загрузкой himem.sys - windows загружает его автоматически. В win.ini проверьте строчки run= и load= в самом начале файла и удалите то, что вам не нужно.
- Проверьте папку Start-up в вашем меню Programs. Некоторые программы (например, Microsoft office) очень любят записывать туда разнообразные программы, которые в принципе никому не нужны, а ресурсы забирают. Удалите все, что вам не нужно.


Программы в автозагрузке

Существуют сайты, на который выложены целые списки программ, стартующих вместе с системой. Часть этих программ вполне можно отключить для экономии ресурсов. Для начала небольшой совет - найдите на своем диске файл, который прописан у вас в автозагрузке и загляните в его свойства - исходя из его названия, расположения на диске или имени разработчика можно определить хотя бы примерно, к какой из установленных программ он относится, и сделать выводы
- выполняет он какие-то полезные функции или от его запуска вполне можно отказаться. Так, например, понятно, что утилита Corel Registration Reminder (remind32.exe) предназначена для еженедельного донимания пользователя с просьбой зарегистрироваться и ее отключение не только полезно для нервной системы, но и не повлияет на функциональность других приложений. А вот отключив утилиту CPUcool (cpucool.exe), вы перестанете использовать программное охлаждение процессора до тех пор, пока не запустите ее вручную. Так что в каждом случае принимать решение пользователю приходится самолично. Мы приведем только малую часть программ из числа наиболее известных

  • Access Ramp Monitor (armon32.exe) - отслеживает параметры интернет-соединения, запрещает запуск некоторых игр.
  • Album Fast Start (abmtsr.exe) - утилита для сканера, для его нормальной работы не требуется, доступна из меню "Пуск".
  • Alogserv (alogserv.exe) - утилита для ведения протокола работы McAfee VirusScan.
  • Bpcpost.exe - Microsoft TV Viewer Post Setup Program - часть Microsoft WebTV for Windows.
  • BrowserWebCheck (loadwc.exe) - проверяет, является ли Internet Explorer браузером, используемым по умолчанию. Не требуется.
  • ConMgr.exe (conmgr.exe) - запускает WinFax Pro, нужна для ответа на входящие звонки.
  • CtfMon (ctfmon.exe) - прописывается в автозагрузку при каждом запуске Office XP, нужна для альтернативных способов ввода текста, поэтому если диктовка не используется, то лучше отключить через апплет Text Services and Speech в Панели управления.
  • CyDoor (CT_Load.exe) - засасывающая рекламу spyware-утилита. Желательно удалить вместе с программой-маткой. Поможет в этом утилита AD-aware (www.lavasoft.de/aaw).
  • EM_EXEC (em_exec.exe) - драйвер мыши Logitech. Нужен для поддержки дополнительных функций мыши или трекбола.
  • Fpx (mnmsrvc.exe) - служба Remote Desktop Sharing, часть Microsoft NetMeeting.
  • Gator (gator.exe) - еще одна шпионско-рекламная программа.
  • HIDServ (hidserv.exe) - Human Interface Device Server, нужен, только если используется какое-то USB-аудиоустройство, например мультимедийная USB-клавиатура с регулятором громкости.
  • Internat (internat.exe) - индикатор раскладки клавиатуры в системной области панели задач. Для самого переключения не требуется.
  • LoadPowerProfile (powrprof.dll) - отвечает за управление питанием и загрузку соответствующих профилей. Обычно грузится два раза, и один из экземпляров можно отключить.
  • Machine Debug Manager (mdm.exe) - дебаггер, нужен разработчикам и тестерам ПО. Крайне рекомендуется отключить.
  • MDAC_runonce (runonce.exe) - ассоциировано с Microsoft Data Access Components (MDAC). Автозагрузка не требуется, но наличие на диске самой системной утилиты runonce.exe необходимо. Microsoft Office Shortcut Bar (msoffice.exe) - панель быстрого запуска, входящая в состав Office.
  • MOSearch (mosearch.exe) - утилита Fast Search в Office XP, аналогична FindFast из Office 2000. Потребляет много ресурсов, лучше отключить, если не работаете с тысячами документов.
  • MSBB (msbb.exe) - очередная шпионская программа, загружает рекламу на ПК и шпионит за пользователем. Отключайте.
  • MSConfigReminder (msconfig.exe) - при загрузке ОС сообщает, что вы что-то отключили в программе "Настройка системы".
  • Netzip Smart Downloader (npnzdad.exe) - spyware-утилита, закачивает рекламу на ПК без ведома пользователя и отслеживает его действия.
  • New.net (rundll32.exe NewDotNetStartup) - опять шпион.
  • PCHealth (pchschd.exe) - в Windows Me планировщик системы PC Health, при отмене его загрузки PC Health не отключается.
  • PWSTray (pwstray.exe) - Microsoft Personal Web Server, можно запустить и вручную.
  • QuickSort (qsort.exe) - утилита для сортировки пунктов меню "Пуск" по алфавиту - не требуется.
  • RealDownload Express (npnzdad.exe) - снова любитель качать рекламу на компьютер.
  • Resource Meter (rsrcmtr.exe) - индикатор ресурсов Windows, можно запускать вручную.
  • SaveNow (savenow.exe) - опять рекламный шпион.
  • ScanRegistry (scanregw.exe) - системный сканер реестра, делает также его резервные копии. Очень ценная вещь, в памяти не остается.
  • SchedulingAgent (mstask.exe) - "Планировщик заданий". Если не используется - отключить.
  • StateMgr (statemgr.exe) - отвечает в Windows Me за службы System Restore и System File Protection - если они не требуются, то можно отключить.
  • Synchronization Manager (mobsync.exe) - Internet Explorer Synchronization Manager - для повседневной работы не нужен.
  • SystemTray (systray.exe) - System Tray Services, выводит в системной области панели задач значки Volume Control, PC Card Status и Power Management.
  • TaskMonitor (taskmon.exe) - отслеживает ход запуска программ и поставляет эти данные дефрагментатору для оптимизации расположения файлов на диске. Полезная вещь.
  • TimeSink Add Client (tsadbot.exe) - один из самых распространенных шпионов.
  • W3KNetwork (rundll32.exe w3knet.dll,dllinitrun) - очередное spyware.
  • Winmodem (wmexe.exe) - нужен для функционирования некоторых вин-модемов.


Службы в Windows

Ускорить работу системы, попутно освободив немного памяти, можно запретив загрузку ненужных системных служб. Отключить ненужные службы можно через раздел Services окна Computer Management. Здесь надо быть предельно осторожным, потому как последствия необдуманных действий могут быть непредсказуемы. Многие службы для своей работы требуют работы других служб, поэтому если Вы отключите слишком много лишнего, то можете столкнуться с такой ситуацией, что не сможете включить всё обратно. Какая служба от какой зависит можно посмотреть через закладку Dependencies из свойства службы. Но чтобы полностью избежать проблем при экспериментах со службами, мы бы советовали вам перед тем как производить эксперименты с службами сохранить ветку реестра отвечающую за запуск системных служб. Для этого в реестре найдите раздел HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet \Serviсes. Ниже мы приведём несколько служб, которые могут быть отключены. Используйте эти советы на свой страх и риск, авторы не несут никакой ответственности за возможные последствия (список служб дан для XP Pro).

  • Print Spooler: Спулер печати, ускоряет печать; если принтера нет, то его можно отключить.
  • Automatic Updates: Автоматичесткое обновление. Если у вас нет постоянного соединения с Интернетом, или если вы просто хотите контролировать всё что делает компьютер, то обновлять программное обеспечение входящее в состав XP можно и вручную. Выключая эту службу не забудьте выключить Automatic Updates в одноименной закладке System Properties.
  • Cryptographic Service: Отвечает за безопасный обмен ключами и шифрование. Используется для установки защищённых соединений, как в локальной сети, так и в интернет, играет важную роль в поддержке шифрования файловой системой. Если вам не надо шифровать файлы находящиеся на NTFS разделах, и вы не планируете использовать защищённые соединения в интернет (что использует, например, Windows Update), можете эту службу отключить. Используется она и во время проверки системных файлов (команда sfc), поэтому перед такой проверкой не забудьте включть её обратно.
  • Portable media serial number: Обеспечивает получение серийного номера переносного музыкального устройства подключаемого к компьютеру. Очередное нововведение Microsoft в рамках борьбы с музыкальным пиратством. На сегодняшний день для большинства из нас эта служба не актуальна.
  • SSDP Discovery service: обеспечивает автоматических устройств подключаемых к сети устройств, поддерживающих UPnP. Пока что это редкость.
  • Terminal Service: Раньше эта служба была доступна только в серверных вариантах ОС. Она позволяет подключаться к Вашей машине про сети, и удалёно работать на ней. В XP Pro эта служба предназначена для удаленного администрирования Вашей машины, чтобы IT специалисту не приходилось бегать самому чинить всё что Вы там натворили, а можно было сделать это удалённо. Кроме этого, через эту службу работает переключение пользователей на одной машине (Switch User). Если Вам эти возможности не нужны, можете отключить эту службу.
  • Windows time: синхронизирует время на локальной машине и сервере. Нет time-сервера - служба не нужна.
  • Messenger: Принимает и отправляет сообщения, посланные администратором. Если нет сети и администратора, то можно отключить.
  • Protected Storage: Служит для защиты важных данных, ключей пользователей. Запрещает неавторизированный доступ. Если нет сети (в том числе Интернет), или безопасность не волнует, то данный сервис можно отключить.
  • Computer Browser: Обновляет список компьютеров в сети. Если у вас нет локальной сети, то можно отключить.
  • Server: Обеспечивает общий доступ к принтерам, папкам и файлам, а также обеспечивает поддержку Remote Procedure Call. В случае, если у вас нет ни сетевой карты, ни модема, он вам не нужен.
  • Network Connections: Занимается управлением объектами в директории Network and Dial-Up Connections, то есть всеми сетевыми соединениями. Если нет сети, то он становится не нужным.
  • DHCP client: Отвечает за автоматическое распределение IP-адресов. Если нет сети (ни локальной, ни модема), то он не нужен.
  • Telephony: Работает с модемом. Если модема нет, то он не нужен.
  • Telnet: Обеспечивает возможность соединения и удалённой работы с хостами по протоколу telnet. Если уверены, что это не пригодится, то данный сервис можно отключить.

Этот список можно ещё продолжить, необходимость того или иного сервиса определяется задачами, которые выполняются на конкретной машине, и установленным аппаратным обеспечением. Поэтому каждый должен сам решать, что можно отключить.


Перезагрузка, выключение компьютера

Windows перезагрузится быстрее, если, при выбранном "Перезагрузить компьютер", удерживая Shift нажать ОК.

Если Вы хотите, чтобы после выбора меню "Перезагрузить в режиме эмуляции MS-DOS" у Вас, после завершения работы Windows автоматически запустилась какая-то программа (например, Нортон командир), то впишите необходимые команды в файл dosstart.bat, который находится в папке Windows.

Чтобы обновить изменения в реестре без перезагрузки компьютера нажмите Ctrl+Alt+Del, выберите из списка explorer и нажмите "Снять задачу". Откажитесь от выключения компьютера, в появившемся через несколько секунд окне нажмите "Снять задачу" и через еще несколько секунд оболочка Windows перезагрузится с новыми параметрами.


"Обрезание" виндов

В том случае, если уже установлено все оборудование, можно удалить папку %SystemRoot%\Driver Cache\i386\ (т.е. по умолчанию C:\Windows\Driver Cache\i386\). Правда, в этом случае при добавлении любого нового оборудования Windows будет запрашивать установочный CD

И еще одну папку можно удалить - %SystemRoot%\system32\dllcache\ (в ней хранятся защищенные системные файлы, используемые для автоматического восстановления оригиналов в случае их повреждения). Кстати, по умолчанию размер этой папки - 400 мб (он задается в реестре параметром SFCQuota (0xFFFFFFFF), находящемся в ключе HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon, но его можно изменить до нуля программой sfc: sfc /cachesize=0 (если поставить, например, 10, то размер папки уменьшится до 10 мб)


Сеть

Освобождение канала (bandwidth), зарезервированного за сервисом QoS.
Это такая хитрющая штука, о которой я бы вжись не догадался, если бы не прочитал на сайте улучшалок ХР. Как оказалось, Windows XP по умолчанию выделяет часть интернет-канала для очень полезной штуки, которая называется Quality of Service (QoS). Назначение QoS - улучшать распределение трафика программ, написанных с учетом QoS API. Другое дело, что этих программ днем с огнем не сыскать (вернее, у меня лично они не стоят), поэтому резервирование канала под ненужный сервис - непозволительная роскошь. Вот что нужно проделать для того, чтобы освободить и без того узкий канал отечественного соединения с интернетом:
- В меню Start - Run запустите редактор групповых полисов: gpedit.msc. Имейте ввиду, что для выполнения всех этих процедур вам необходимо войти в систему как Администратор.
- В разделе Computer Configuration (в левом окне) выберите Administrative Templates.
- Далее Network и затем в правой панели выберите QoS Packet Scheduler и кликните на нем два раза.
- Выберите опцию limit reservable bandwidth и опять-таки кликните на ней два раза.
- В открывшемся окне включите Enabled, а затем укажите лимит канала в процентах равный нулю.
- ОК и выйдите из программы. Но это еще не все.
- Отправляйтесь в сетевую конфигурацию (иконка Network Connections в Контрольной панели).
- Выделите свое соединение и из контекстного меню запустите Properties.
- В закладке Networking убедитесь, что протокол QoS Packet Scheduler подключен (enabled). Если его там нет, то добавьте из списка (через кнопку Install).
- Перегрузите компьютер.
Все эти сложные пассы с насильственным включением сервиса и последующим выделением под него нулевого канала вызваны тем, что если просто отключить Quality of Service, то, как это часто бывает у наших антипятов, система все равно будет резервировать под него 20 % канала.

Если набрать
net send "имя компьютера" message
в пункте меню "Пуск"->Выполнить, то на компьютере "имя компьютера" появится окно c сообщением. Очень удобно переговариваться в сети. Вместо "имя компьютера" можно использовать ip-адрес.
Работает на NT, 2000. Чтобы работало в Win9x надо запустить winpopup.

Если в конце имени расшаренного ресурса поставить символ "$" (без ковычек), то этот ресурс будет не виден в сети. Доступ к нему можно будет получить, только обратившись к нему напрямую.


Файл подкачки

Windows 9x/Me активно использует файл подкачки, значительно разгружая оперативную память компьютера. По неизвестным причинам Microsoft сделала файл подкачки динамическим, т.е. размер файла изменяется в зависимости от нужд Windows, хотя наилучшая производительность системы достигается при статическом файле. Причин для этого множество - Windows не требуется каждый раз изменять размер файла подкачки, исчезает фрагментация и т.д. Для того чтобы изменить параметры файла подкачки, щелкните правой кнопкой мыши на значке "Мой компьютер" и выберите Свойства. Перейдите на вкладку Производительность и щелкните кнопку Виртуальная память (Properties->Performance->Virtual Memory). В появившемся окне выберите "Параметры виртуальной памяти устанавливаются вручную" (Let me specify my own virtual memory settings). Если у вас установлено более одного жесткого диска, рекомендуется перенести файл подкачки с диска, где у вас установлена Windows на другой жесткий диск, более быстрый. Это должно значительно увеличить производительность системы. Теперь установите размер файла виртуальной памяти. Рекомендуемый размер - хотя бы в 2,5 раза больше, чем объем оперативной памяти. Перезагрузите систему и запустите утилиту дефрагментации для того, чтобы быть уверенным, что файл подкачки не фрагментирован. А если вы пользуетесь дефрагментатором сторонних производителей, в опциях укажите, чтобы файл подкачки располагался в начале диска.

Для компьютеров, оснащённых более чем 64 MB оперативной памяти, можно порекомендовать следующий "трюк": в файле system.ini, который находится в каталоге C:\Windows, в разделе [386Enh], необходимо дописать строку ConservativeSwapfileUsage=1
Это позволит системе не создавать файл подкачки без необходимости. Например, со 128 MB оперативной памяти можно будет открыть до трёх офисных приложений, таких, как Word, Excel и Internet Explorer, притом, что размер файла подкачки останется равным нулю. То же самое произойдёт при запуске Quake 3.

Если файл подкачки не "консервировать", то приложений открыть можно будет гораздо больше, а игр запустить хоть две, одновременно. Надо бы, авторам советов, не забывать, как мне кажется, что читают их в том числе и чайники, и для них они достаточно авторитетны, а по сему стараться быть объективней или хотя бы давать советы более корректные.
Небольшой комментарий от ведущего: в принципе, верное замечание. Однако, в большинстве случаев "консервировать" файл подкачки можно, т.к. сейчас средний компьютер имеет 128 Мб оперативной памяти, плюс около 300 Мб виртуальной памяти (при коэффициенте 2,5), что дает более 400 Мб суммарно. В 99% случаев этого хватает с избытком. Но бывают и исключения, поэтому не стоит слепо следовать советам, а немного подстраивать их под свои условия. Ведь можно установить размер виртуальной памяти и в 4-5 раз больше. Экспериментируйте. Это не "убьет" Windows.

Как оптимально настроить файл подкачки - несколько советов.
Если у Вас несколько винчестеров (не разделов, а именно винчестеров), то установка файла подкачки на другой винт, чем установлена операционная система, обычно значительно ускоряет быстродействие.
Если у Вас несколько винчестеров - то файл подкачки ставится на самый быстрый из них.
Если у Вас несколько разделов на винте, то файл подкачки надо ставить на самый первый из них - физически расположенный самым первым, так как доступ к этим областям винта наиболее быстрый.
Целесообразно ограничить минимальный объем файла подкачки, чтоб предотвратить излишнюю его фрагментацию примерно объемом 1-1.5 объема вашей оперативной памяти (впрочем если Вы пользуете графику или напрягаете компьютер серверами баз данных то можно поставить размером 2-3 объема RAM).
Практически не имеет резона ограничивать максимальный объем, так как это может привести к сбою программ из-за нехватки памяти, а если уж и ограничивать, то никак не меньше чем 4 объема RAM.
После этих настроек комп надо перезагрузить и запустить какой-нибудь дефрагментатор (типа Norton Speed Disk) чтоб полностью дефрагментировать файл подкачки и поместить его в начало раздела.
И последнее, помните, что после выключения компьютера файл подкачки может содержать Ваши пароли, логины, остатки Вашей конфиденциальной информации и т.п., так что достаточно "образованные дяди" из числа Ваших доброжелателей или компетентных органов, загрузившись в ДОС и покопавшись в объедках Ваших программ в файле подкачки могут найти очень интересные вещи...


Autorun

Все, наверное, видели, как при установке компакта с игрушкой иконка сидюка менялась на иконку игрушки, и многие знают, как это делалось. А если кто не знает - скажу. Всё дело в файле AUTORUN.INF, который лежит в корне сидюка. Он примерно такой:
[Autorun]
icon=icon.ico
Если же такие файлы переписать на винт, то поменяется иконка харда.

Расширенное описание файла Autorun.inf

[Autorun]
Open=Autorun.exe
Icon=Autorun.exe ,0
Shell\About=About CD
Shell\About\Command=Notepad.exe About.txt

 Перед параметрами Open, Icon, Shell\..., Shell\...\Command обязательно должна быть строка [Autorun] (в INI и INF файлах в квадратные скобки заключаются имена разделов).

Описание параметров:
Open | Командная строка, автоматически выполняемая при вставке диска или при выборе в контекстном меню диска пункта Автозапуск. Например: Open=Autorun.exe или Open=Notepad.exe List.txt
Icon | Полные путь имя файла со значком и номер значка в нем. Формат: Icon=File.exe ,n File.exe - полные путь и имя файла со значком n - номер (отсчет начинается с нуля) значка в файле
Shell\name | Описание дополнительного пункта контекстного меню диска. Формат: Shell\mname=mtext Shell\mname\Command=cmdline mname - имя пункта меню mtext - текст пункта меню cmdline - командная строка, выполняющаяся при выборе этого пункта меню.

Примечание:
Если параметр Shell\...\Command указан без параметра Shell\..., то в меню будет выведено либо системный текст, либо имя пункта меню.
Примечание:
Файлы Autorun.inf могут работать не только на жестких дисках и CD, они могут работать и на съемных дисках. Для этого надо с помощью программ тонкой настройки Windows включить автозапуск со съемных дисков. Например, в программе XQXSetup эта настройка находится по адресу: System\File System\CD Autostart\Autostart Data CD


BAT-файлы

Если Вам требуется последовательно запускать несколько программ Windows, то Вы можете написать для этого .bat файл. Используйте команду START с ключом /W. Например создайте текстовый файл со следующим текстом:

@START /W /MAX "C:\WINDOWS\SCANDSKW.EXE /A /N"
@START /W /MAX "C:\WINDOWS\DEFRAG.EXE /ALL /F /NOPROMPT"

И сохраните его как 1.bat (обратите внимание на кавычки!). Кроме /W, Вы можете использовать следующие ключи:
/M Запускает программу минимизированно
/MAX Запускает программу, развернув на весь экран
/R Запускает программу в окне (используется по умолчанию)

Передача параметров в bat-файл.
Для того чтобы bat-файл можно было запускать с какими-то параметрами надо в том месте файла, куда вы хотите добавить параметр, набрать %1 - для первого параметра, %2 - для второго и т.д.
Например (файл test.bat):

/тут идут какие-то
/.....
/подготовительные работы
rar m file%1

Теперь если вы запустите этот файл командой "test.bat 0001", то у вас будет создан файл с именем file0001.rar


desktop.ini

Содержимое файлов desktop.ini

[.ShellClassInfo]
CLSID={...}
InfoTip=YOUR TIP
IconFile=C:\Windows\System\Shell32.dll
IconIndex=0

 CLSID - имя папки для регистрации в раделе реестра HKEY_CLASSES_ROOT\CLSID
InfoTip - комментарий к папке IconFile - имя файла со значком для папки
IconIndex - номер значка в файле, указанном в параметре IconFile(нумерация начинается с нуля)

Каждый независимый параметр можно использовать отдельно от других.
Указав CLSID в файле desktop.ini, можно создав соответствующий ему раздел в реестре, оперировать с папкой, содержащей desktop.ini, как с типом файлов.
Параметры InfoTip, IconFile, IconIndex возможно работают только на Windows ME или Windows 2000.
Чтобы применить настройки файла desktop.ini надо:
* Если файл существовал до внеснения изменений, то обновить содержимое папки.
* Если файл был создан Вами или первый способ не помог, то
1.Выбрать Настроить вид папки в меню проводника Вид.
2.Выбрать настройку фона папки и шрифта.
3.Не изменяя текущих настроек, нажимать кнопку Далее.
4.Нажать кнопку Готово.

Папки, которые содержат desktop.ini со следующим содержимым:
CLSID={...}
или
UICLSID={...}
можно добавить в любую папку, создав в ней папку с именем ИМЯ.{...}, где {...} - значение ключа CLSID (UICLSID) из файла desktop.ini .
Примечание:
Не гарантируется, что в созданных папках будет повторятся содержимое папок с desktop.ini, но на системные папки, зарегистрированные в CLSID, это скорее всего подействует.
Некоторые не существующие физически папки, зарегестрированные в разделе реестра HKEY_CLASSES_ROOT\CLSID можно добавить таким же образом.


О Виндах и двух винтах

Винду, как один большой глюк можно исследовать бесконечно. Но, в процессе изучения, винда часто падает и очень серьёзно. В конце концов мне надоело её ставить (или обновлять). Помните как в ДОСе: sys c:, а затем переносится папочка ДОС... Так вот с тех пор произошли существенные изменения. Исчезла необходимость команды sys с:! Для такого изврата необходимо только одно условие - два винчестера. Думаю это уже не проблема, так как винты дешевеют быстрее чем ломаются и найти маленький винт на пару гиг ещё можно. (У меня маленькая дискетка на 8 гб :)

Зачем это надо?
1. Мне лень переустанавливать винды. Сам процесс занимает немного времени, но установка остальных программ является настоящим адом.
2. Люблю брать различные компашки с различным софтом и смотреть как он работает. После софта в реестре остаётся много различного мусора, который очень сильно влияет на размер реестра, и в конце концов, на скорость машины.
3. На работе часто приходится устанавливать винды на новые машины, а кому понравится когда его отвлекают.
4. Дома стоит Миллениум, из которого убраны руками множество ненужных на мой взгляд функций. Второй раз повторить это будет сложно.

Вроде указал большинство причин. Итак:
Берем работающую винду, запускаем под ней виндовс коммандер (можно воспользоваться любым файл-менеджером, главное что бы он понимал длинные имена). Устанавливаем в обоих окошках командира: "Показывать скрытые/системные файлы", вид - "все файлы", "без сортировки". В виндовс командире я убираю ещё птичку с "в обратном порядке". То есть мы готовимся копировать все файлы в том порядке, каком они идут на жёстком диске. Берём с диска с: папки "виндовс", "программные файлы" и файлы в корневой директории (это обязательный список) и копируем на другой винт, предварительно отформатированный (или по крайней мере ПОЛНОСТЬЮ очищенный от всех файлов). Можно не обязательно на чистый диск, можно сделать резервную копию - просто скопировать на какой-нибудь диск, но тогда этот диск НЕЛЬЗЯ оптимизировать никаким дефрагментатором. На ругань виндозы, типа не вижу файл Win386.swp сказать - пофигу.
Итак, скопировали.
Перегружаем машину, устанавливаем в БИОСе загрузку с этого винта. Оппа! Поехала! Значит всё сделано правильно.
Я так устанавливаю виндозы на новые тачки: лежит у меня на винте копия только что установленной винды (+оффис, инсталляция, работающая сетка). Винт с новой тачки снимаю и цепляю к себе. Копирую копию винды на винт. Запускаю его на новой машине. ВСЁ! 5 минут, а уже имеем работающий компьютер с установленным оффисом!!! (Сборщикам компов - всем поднять за моё здоровье ;) Остаётся настроить сеть, поменять драйвера и нервы ваши опять гладкие и шелковистые...
Дома я так делаю когда у меня накопятся всякие программы или захочется покопаться мне в реестре и покастрировать винду. Запускаюсь с копии и работаю. Если понравилась прога, то и на основном винте ставлю.
Кстати, в таком использовании двух винтов есть ещё очень большой плюс. Большинство устанавливаемых программ можно ставить только один раз в жизни, на копию винды. Если потом перегрузиться на основной винт и попробовать её запустить, то в 80-90% она работает без ущерба для здоровья. Исключение составляют здоровые пакеты чего-нибудь, которые пишут свои ДЛЛки в System, или ещё куда-нибудь. И те проги, которые итегрируются в системы (оффис). Их придётся ставить каждый раз. Все остальные можно смело копировать на какой-то выделенный диск и пользоваться независимо от количества установок виндозы. Зачем каждый раз повторять инсталляцию?

Некоторые проги (Нортона утилиты, Nuts&Bolts, VisualRoute) несмотря на то что и пишут куда-то свои ДЛЛки, но позволяют скопировать эту ДЛЛку к себе в каталог и запускаются без проблем. Вообще, чтобы скопировать такой пакет утилит надо посмотреть у него в папке uninstall файл, там часто в некодированном виде расписано где что положено и откуда всё брать.


Игры

Пасьянс "Косынка"
При сдаче по три карты удерживая одновременно Ctrl, Alt и Shift, можно снимать с колоды по одной карте

Пасьянс "Солитер"
Нажмите одновременно Shift, Ctrl и F10. Теперь Вы можете выбрать, получится разложить Вам этот расклад, или нет. Нажмите F3 для выбора расклада, выберите расклад -1 или -2. Перед Вами появится очень необычный расклад.

Логическая игра "Сапер"
Щелкните по полю, чтобы началась игра. Одновременно нажмите обе кнопки мыши. На экране должен появиться квадрат 3х3. Нажмите Esc. Теперь часы в игре остановились. Для возвращения в обычный режим нужно свернуть и развернуть обратно окно игры.


Приколы и "пасхальные яйца" в программах

Попробуйте на рабочем столе создать ярлык и в командной строке вписать буквально следующее:
"C:\WINDOWS\Application Data\Microsoft\WELCOME\WELDATA.EXE" You_are_a_real_rascal
Разумеется, что вместо C:\WINDOWS следует подставить именно тот каталог в который вы установили Windows 98. В свойствах ярлыка нужно указать, что приложение должно запускаться "Свернутым в значок". Также можно набрать в командной строке:
start /m "C:\WINDOWS\Application Data\Microsoft\WELCOME\WELDATA.EXE" You_are_a_real_rascal (ключ /m означает запуск приложения свернутым в значок). ... Запускаем... теперь становится понятно, почему наш мелкософт так много места занимает :))). Вам будет показан небольшой фильм со слайдами так или иначе связанными с Microsoft и прокручивающимся списком людей, принимавших участие в разработке операционки (и как Билл Гейтс не попал на первое место?) на фоне ненавязчивой музыки. Проверено в Windows 98

Классический прикол, срабатывающий на тех, кто уже знает кнопку "Пуск" ("Start"), но не знает всех особенностей Windows 95... Когда этот самый новичок в мире Windows 95 на минуту уйдет в другую комнату, вы быстро подбегаете к его компьютеру, выделяете (но не нажимаете) кнопку "Пуск", жмете ALT +"минус" и... "Закрыть". Дальше вы возвращаетесь на исходную позицию, и наблюдаете за реакцией новичка... Кнопка вернется на место только после перезагрузки Windows'a.

Далее следует прикол, более сложный в исполнении:
- На рабочем столе создайте папку с именем New Folder.
- Переименуйте ее в and now, the moment you've been all waiting for.
- Еще раз переименуйте ее в we proudly present for your viewing pleasure.
- И снова переименуйте в The Microsoft Windows 95 Product Team!.
- Теперь откройте папку и наслаждайтесь именами тех, кто создал "сверх устойчивую систему". По моему, стабильность системы прямо пропорциональна количеству приколов, намертво вшитих в нее.

Неплохо работала фантазия и у тех, кто создавал хранители экрана для Windows 95 и NT. В основном приколы зарыты в хранителе экрана "Объемный текст" ("3D text"):
В зависимости от версии Windows 3D Text реагирует на следующие "волшебные" слова, заданные в качестве текста для отображения: I love NT (в версии 3.51), not evil (в версии 4.0), volcano (Windows 95 и NT), BEER и Rock (в версии 3.51).

Но есть прикол и для хранителя экрана под названием "Трубопровод":
Если для Windows NT в этом хранителе экрана задать параметр "чередующиеся сочленения", то переодически вместо соединения будет появляться чайник. Интересно, к чему бы это?
В Windows 95 этот трюк тоже проходит, если помимо "чередующегося сочленения" поставить параметр "число труб" в значение "несколько".

Если в Win95/98 залезть в параметры заставки "Объемный текст" и в поле "Текст" набрать Volcano, заставка будет выдавать названия различных вулканов


Стандартные программы

Хорошо ли вы знаете Windows? Я думаю, что да. Знаете ли вы его на 100%? Вряд ли. Потому что программисты из Microsoft очень постарались, пряча некоторые функции и возможности от пользователей. Речь здесь пойдет о программах: самых обычных стандартных программах операционной системы, которые при установке ставятся по умолчанию и присутствие которых никак не афишируется. Более того, разработчики, как нарочно, пытаются отпугнуть пользователей от работы с этими утилитами. Посудите сами: программы нигде не упоминаются (ну, может быть в справке), на них нет ярлыков в меню "Пуск", а при попытке зайти в каталог Windows, где они, собственно, и находятся, появляется страшная надпись о том, что сюда заходить не надо, дабы не испортить системных файлов. Это может отпугнуть новичков. А ведь там немало полезных программ.

Paint

Оказывается, в Microsoft Paint можно быстро увеличить картинку аж в 10 раз. Для этого активизируйте инструмент Лупа. В нижней части поля, где фиксируется степень увеличения, находится тонкая белая линия. Аккуратно щелкните по ней. Как себя чувствует ваша картинка?

Если при работе в Paint, во время рисования линии удерживать нажатой клавишу Shift, то будет рисоваться прямая линия. Если проводить линию под углом, то при этом угол будет составлять 45 градусов.

А если удерживать нажатой клавишу Shift при рисовании фигур, то будет рисоваться квадраты и круги, вместо прямоугольников и эллипсов.

Планировщик заданий

Вы пользуетесь планировщиком заданий? Если нет, то лучше отключите его: он только "отъедает" лишнюю оперативную память, замедляет загрузку компьютера и занимает место в трее. Сделать это не просто, а очень просто. Для Win9x запустите редактор реестра и в разделе HKEY_LOCAL_MACHINE\Software\ Microsoft\Windows\Current Version\RunServices\ удалите параметр "SchedulingAgent". Для Win NT/2000 надо зайти в Панель управления - Администрирование - Службы и остановить "Планировщик заданий".
Замечание:
Совсем не обязательно буждать по реестру для отключения планировщика в win9x. Для этого кликаем по иконке планеровщика с трэе (он запускается), выбираем в меню "Дополнительно" пункт "остановить планировщик". Всего то.

Блокнот

Блокнот можно очень удобно использовать для ежедневных заметок. Если в первой строке написать .LOG (буквы должны быть большими), то каждый раз при его открытии курсор будет устанавливаться на конец файла, а перед ним будет автоматически вводиться текущая дата и время.

Калькулятор

Если в окно Калькулятора вставить из буфера обмена строку чисел, разделенных знаками простейших арифметических действий (+, -, *, /), оканчивающуюся знаком равенства, то калькулятор автоматически вычислит последовательно все действия, и на его "индикаторе" появится результат, который при необходимости можно легко перенести в любое работающее приложение Windows посредством того же буфера обмена. Это очень удобно, когда нужно быстро выполнить вычисления, особенно если их текст уже набран, например, в документе текстового редактора, в который нужно вставить результат вычислений. Пробелов в выражении можно не делать, хотя они обычно не мешают. В конце обязательно поставьте знак равенства, иначе последнее действие окажется не выполненным и в этом случае придется нажать [Enter] либо щелкнуть на клавише со знаком равенства.
Результат вычислений, выполняемых по такой методике, зависит от того режима, в котором находится Калькулятор. В Обычном режиме строка символов воспринимается как простая последовательность нажатий соответствующих клавиш, не отдавая приоритета операциям умножения и деления.
В Инженерном виде вычисления производятся по всем правилам, можно даже использовать скобки и некоторые специальные последовательности символов-кодов, выполняющих служебные функции:
Специальные коды
:q Начало нового вычисления.
:c Очистка памяти.
:e Ввод десятичных чисел в экспоненциальной нотации.
:m Запоминание числа в памяти.
:p Добавление текущего числа к хранящемуся в памяти.
:r Вызов числа, хранящегося в памяти.

MKCOMPAT.EXE

Если Вам требуется работать с какой-либо программой для Windows 3.1, то Вы можете воспользоваться специальной утилитой MKCOMPAT.EXE, которая находится в папке Windows\System. Эта утилита предназначена для того, чтобы сделать программы от 3.1 более совместимыми с 95.

Редактор реестра (Regedit.exe)

Для того, чтобы импортировать в реестр данные из reg файла без запросов, запустите его с ключом /s. Например:
regedit /s test.reg

Есть простой способ отследить изменения, которые происходят в реестре Windows. Запустите Regedit ("Пуск" > "Выполнить" > "Regedit.exe") и экспортируйте файл реестра ("Файл" > "Экспорт файла реестра"), сохранив его под любым именем, например, before.reg. В момент, когда захотите проверить изменения в реестре, совершите ту же операцию (сохранив файл, например, after.reg). Теперь активируйте строку MS-DOS и в директории, где находятся эти два файла, наберите: FC before.reg after.reg > diff.txt. Открыв файл diff.txt в любом текстовом редакторе, вы увидите все изменения, которые произошли в реестре.
Кстати, FC - это внешняя команда DOS для сравнения файлов и выведения различий в них. Чтобы узнать о команде побольше, наберите FC /? в строке MS-DOS.

По мере установки различных программ размер системного реестра Windows неумолимо растет. Кроме того, при удалении записей из него физически из файлов реестра они, конечно же, не удаляются, а лишь помечаются как удаленные. Очевидно, что чрезмерная громоздкость реестра приводит к общему снижению производительности системы. Несмотря на то что сегодня уже есть десятки специальных утилит чистки реестра, сжать его по максимуму можно и вручную достаточно тривиальным способом.
Для начала экспортируйте весь реестр в единый REG-файл. Самый простой метод - перейти в папку Windows и выполнить в командной строке команду REGEDIT.EXE /E REGIMAGE.REG. Запуск редактора реестра с ключом /E произведет экспорт всего содержимого реестра в указанный после ключа файл (REGIMAGE.REG).
Далее перегрузитесь в режиме эмуляции MS-DOS и удалите файлы системного реестра SYSTEM. DAT и USER.DAT, располагающиеся в корневой папке Windows, предварительно создав их резервные копии. Для восстановления системного реестра из заранее подготовленного REG-файла выполните команду REGEDIT.EXE /C REGIMAGE.REG, находясь в папке Windows. После завершения импорта реестра перезагрузите компьютер.
ВНИМАНИЕ! Подобные операции с системным реестром при определенных условиях могут привести к полному отказу системы. Выполнять их рекомендуется только квалифицированным пользователям, способным оценить необходимость их применения. Если вы все-таки решили испробовать этот совет, обязательно создайте резервную копию реестра. Кроме того, импорт REG-файла в DOS-режиме может занять несколько десятков минут, а то и больше.

Для разборки и понимания реестра я сохранил весь реестр в файл (через regedit), а потом с помощью Disco Commander (в качестве вьювера) лазил и смотрел, что можно поменять и что более-менее понятно. На мой взгляд, так нагляднее.

drwatson.exe

Для запуска вводим "drwatson" без кавычек в Пуск => Выполнить. После этого кликаем дважды по новой иконке в Области уведомлений ("где часы") и выбираем Вид => Полный режим.
Программа умеет вот что:
- Анализ программных модулей которые могут (не факт, что вызовут) вызывать сбои определенного рода.
- Чуток информации о системе.
- Полный список текущих задач + показ пути к екзешникам.
- Список программ, запускающихся при включении компьютера.
- Инфа о том, какие "системные модули были изменены в памяти".
- Какие модули и приложения перехватывают нажатия клавиш клавиатуры (т.н. "Hook'и").
- Список установленных драйверов ядра системы.
- Аналогичный список драйверов пользователя.
- И драйверов MS-DOS.
- Список 16-разрядных модулей, которые были задействованы при возникновении ошибок.
Часть этой информации получается путем дизассемблирования чего-то. Программа поодерживает печать, сохранение копий данных на диск.
Не думаю, что это может как-то пригодиться новичкам, но функция отлова программ, хукающих клаву мне очень понравилась. Удивительно, почему о ней никто не знает.

Программа настройки системы

Не менее интересна Программа настройки системы, запускаемая с помощью команды msconfig из того же пункта "Выполнить". После загрузки появляется окно с шестью вкладками:
- Общие - позволяет управлять параметрами запуска системы.
- Config.sys - редактирование файла config.sys.
- Autoexec.bat - соответственно.
- System.ini.
- Win.ini.
- Автозагрузка - здесь перечислены все программы, которые запускаются при загрузке системы.
Очень удобно то, что все собрано в одном месте. Не надо лазить по реестру и файлам, чтобы посмотреть, что загружается на компьютере. Можно отключить загрузку любой программы или выполнение строки одного из перечисленных файлов, не правя ничего вручную. При этом комментарии будут расставлены автоматически, а программы, запускаемые из реестра, например, из раздела "Run", будут перенесены в раздел "Run-" (в конце соответствующего раздела добавляется символ "-"). Скажу честно: я сталкивался с такими разделами в реестре, но даже не подозревал что они собой представляют, пока не поэкспериментировал с этой утилитой (я наивно полагал, что это еще один раздел для запуска программ. Ан нет!). Из меню "Вид" можно открыть Панель управления, Диспетчер устройств, папку "Принтеры" и "Шрифты", настройку экрана, параметры мультимедиа. Конечно, использовать ее или нет - дело вкуса. Мне больше нравится все сделать вручную, но для некоторых действий все-таки удобнее использовать программу.

winipcfg

Следующая программа служит для информационных целей. Наберите команду winipcfg (для NT/2000 это ipconfig) и вы увидите настройки TCP/IP протокола. Зачем долго и нудно лазить по различным свойствам в сетевом окружении, если вам надо просто получить немного информации? Гораздо удобнее для этого воспользоваться специальной утилитой. Причем, изначально выдается самый минимум информации, но если нажать на кнопку "Сведения", то окно программы увеличивается и выводится дополнительная информация.


Антивирусные программы

Для тех, кто отдает предпочтение Norton AntiVirus: При установке NAV в Windows XP не отключайте службу "Планировщик заданий" иначе после установки, при инициализации конфигурации произойдет внутренняя ошибка NAV, причем не понятно из-за чего. Методом "тыка" было обнаружено, что эта ошибка происходит при выключенной службе "Планировщика заданий". Совет: Не отключайте эту службу. Сначала установите NAV, при установке отмените проверку каждую пятницу, перегрузите компьютер и затем отключайте службу "Планировщик заданий".

Рекомендуется переименовать антивирусную программу DRWEB.EXE (для маскировки запуска Doctor Web от резидентных вирусов, контролирующих работу DRWEB.EXE). При этом необходимо также переименовать файлы DRWEB.INI, DRWEB.HL1 и DRWEB.HL2 (сохраняя расширения имён).


Печать

Если вам надо что-то печатать на сетевом принтере из ДОСовской программы, которая может выводить данные только в локальный порт LPT1, вам надо перед запуском этой программы в bat-файле дать команду: net use LPT1 \\Computer\Printer где Computer - имя сетевого компьютера, а Printer - имя расшаренного принтера. Это позволит подключить сетевой принтер к порту на вашем компьютере. Команда net use LPT1 /d отключит подключенный ранее сетевой принтер.

О файлах печати.
При установке принтера, можно в качестве порта вывода указать файл. В этом случае всякий раз при попытке распечатать документ на такой принтер, Windows, будет выводить окно с запросом на указание имени создаваемого файла (это окно можно отключить - об этом сказано в одном из предыдущих выпусков "премудрости"). Обычно эти файлы имеют расширение prn.
Зачем могут потребоваться такие файлы?
Если такой виртуальный принтер, печатающий в файл - это PostScript устройство, то далее этот файл можно обработать при помощи Acrobat Distiller и получить в результате документ PDF. Кстати, таким образом можно экспортировать в PDF документы из любой программы, в принципе способной печатать на принтер.
Если на виртуальном PostScript принтере в настройках поставить генерацию кода Eps (encapsulated PostScript), и печатать на нём документы по одной странице, то в результате мы получим файлы encapsulated postscript, расширение у которых можно для удобства переименовать с prn на eps. Такие файлы, кроме уже упомянутой конвертации в PDF, могут использоваться также и для импорта в качестве картинок в другие программы, например, в тот же Word. Только для этого желательно создать в файле миниатюру изображения, иначе он скорее всего будет отображаться в виде серой плашки. Сделать это можно в Adobe Illustrator, в Alladin GhostScript или практически в любом векторном редакторе.
Наконец, файлы prn можно использовать и по прямому назначению. Допустим, у вашего друга стоит принтер, а у вас - нет. И вам надо распечатать документ. Проблема в том, что друг не может распечатать ваш документ, потому что у него нет программы, в котором он создан, да и вообще - друг работает в Linux и слышать не хочет про Windows... Тут-то и выручит файл prn. Вам нужно установить у себя драйвер того самого принтера, который стоит у друга (или, скажем, на работе), только в качестве порта вывода указать файл. Затем - печатаем наш документ, а полученный файл prn несём к другу. Если вы печатали текст, то файл получится небольшим. Далее - на компьютере, к которому непосредственно подключен принтер - копируем этот файл в двоичном режиме прямо на порт принтера. Под Windows для этого вызываем командную строку - выбрав мышью "пуск - выполнить" (или нажав на клавиатуре сочетание Win+R), и вводим "command", если вы делаете это в windows 9x или ME, или "cmd" для windows nt/2k/xp. В командной строке набираем "copy /b файл.prn lpt1", где файл.prn - ваш файл печати с путём к нему (например, a:\myfile.prn), а lpt1 (он же PRN) - порт, к которому подключен принтер. В linux всё делается аналогично - вызываем консоль и набираем команду копирования. Ваш документ будет распечатан.

О файлах PDF.
При распечатке таких файлов на лазерных принтерах без PostScript иногда возникают проблемы с неверной пропечаткой шрифтов (вместо символов печатаются кракозяки). Особенно часто это происходит при распечатке из Adobe Acrobat 5.x
Самое простое - поставить галочку "Print as image". Но при этом скорость печати упадёт примерно в 2-3 раза, а вместе с ним - и качество, поскольку на печать будет выводиться растровая картинка с разрешением 300 DPI.
Другой вариант - воспользоваться гораздо более древним Adobe Acrobat Reader версии 3.x. Он печатает гораздо быстрее и проблем возникает гораздо меньше.
Наконец, на мой взгляд, самый лучший вариант - вообще не пользоваться Acrobat-ом! Скачайте Alladin GhostScript версии не ниже 4.2 и Gsview для него, и забудьте вообще о проблемах с печатью PDF! Эта программа хорошо известна пользователям unix-систем, она быстро запускается, довольно неприхотлива к ресурсам компьютера, и кроме просмотра и распечатки PDF, PS и EPS файлов, включает множество других полезных функций для работы с PostScript документами.

Если Вам часто приходится печатать документы с разными настройками (например, landscape и portrait; чёрно-белые и цветные; высокое и низкое качество печати) на одном принтере, то Вы можете добавить новый логический принтер и установить для него альтернативные настройки.

Поместите на Рабочий стол ярлычок принтера и чтобы распечатать какой-то документ, просто перетащие файл этого документа на созданный ярлычок. Причем, печать будет осуществляться с помощью того приложения, которое зарегистрировано в разделе print в HKEY_CLASSES_ROOT для соответствующего расширения файла.

Как заставить печатать принтер в файл без перезапроса имени файла, т.е. установить файл по умолчанию?
Надо создать файл-порт в Win.ini:
в секции "[Ports]" написать что-то типа
c:\windows\temp\temp.ps=
Обратить внимание что строка заканчивается "=" после которого ничего нет. После перезагрузки для любого принтера в системе будет доступен этот порт. Это работает только в Win95/98/ME, в операционках на базе NT порт берется где-то из реестра, я не копался, пока не надо было.

При отправке заданий на печать на сетевой принтер из приложений MS-DOS может происходить задержка в 60-90 секунд до начала печати, что вызывает остановку работы MS-DOS-приложения в течение этого времени. При завершении работы приложения печать начинается сразу после его закрытия. Такое же поведение может наблюдаться при нажатии клавиши в приложении MS-DOS. Проблема обусловлена тем, что приложение MS-DOS при печати не закрывает принтерный порт. По умолчанию, MS Windows 95 ожидает поступления новых данных в течение 45 секунд, после чего начинает печать документа. Для решения проблемы необходимо отредактировать файл System.ini на том компьютере, где выполняется приложение MS-DOS.
Добавьте в раздел [Network] файла System.ini следующую строку:
PrintBufTime=10
А в раздел [IFSMGR] следующую строку:
PrintBufTime=10
Примечание: Если данные разделы отсутствуют в файле System.ini, то добавьте их после раздела [386Enh].
Значение параметра "PrintBufTime" устанавливает время задержки в секундах до начала печати. Чем меньшее значение используется, тем быстрее начинается печать документа. Однако слишком маленькое значение "PrintBufTime" может приводить к некорректной печати, либо к прекращению вывода задания на печать. В этом случае увеличивайте значение "PrintBufTime" до тех пор, пока не будет достигнута корректная печать.
Параметр, заданный в разделе [Network], управляет задержкой при сетевой печати с использованием редиректора реального режима; параметр, заданный в разделе [IFSMGR], устанавливает задержку при сетевой печати с использованием редиректора защищённого режима. Данные настройки также могут оказывать влияние и на локальную печать.


Панель управления

Совет админам, желающим оградить настройки операционной системы Win9x от слишком любопытных пользователей.
В каталоге Windows есть файл control.ini. С его помощью вы можете настроить какие элементы в Панели управления надо скрыть. Для этого надо в разделе [don't load] добавть название файла элемента, поставить знак "=", а после него "no". Например:

[don't load]
snd.cpl=no

snd.cpl - файл элемента в Панели управления. Эти файлы лежат в каталоге windows\system с расширением cpl. Думаю, по названию файла можно понять, каким элементом он управляет.


Панель управления: Система

Система

Изменим вкладку Система на Панели управления.
Создадим два файла - oeminfo.ini и oemlogo.bmp. Файл oemlogo.bmp создается в любом графическом редакторе (напр. Paint) с размером 160 на 120 пикселов (размеры задаются не жестко, можете немного поэкспериментировать). Файл oeminfo.ini создается в обычном блокноте (Notepad) с таким содержанием:
[General]
Manufacturer=Народные советы
Model=И. Чеботарев, А.Климов

[Support Information]
Line1=За поддержкой обращайтесь по телефону 03
Line2=
Line3=Часы работы:
Line4=Понедельник-Пятница 08.00-16.00
Line5=Суббота-Воскресенье 11.00-12.00!
Line6=

Скопируйте полученные файлы в Windows\System, вызовите вкладку Система на Панели управления и получите удовольствие. Если вы используете секцию [Support Information], появится кнопка Поддержка, в котором будут использованы ваши данные


Панель управления: Язык и стандарты

Язык и стандарты

Для Windows 95/98/Me

Для тех кто забывает какой день недели: "Панель управления" - "Язык и стандарты" - перейти на вкладку "Дата" и в поле "Полный формат" даты добавить дддд в начало или в конец имеющейся записи (получится что-то типа: д MMMM гггг 'г.' дддд). Теперь, если подвести курсор мыши к часам на системной панели, то во всплывающей подсказке увидите день недели и дату. Если у вас используются английские символы, то формат соответственно d MMMM yyyy 'г' dddd

Для Windows XP

Название апплета немного изменилось - "Язык и региональные стандарты". На вкладке Региональные параметры выбираете кнопку Настройка и на появившейся странице Настройка региональных параметров выбираете вкладку Дата. Далее следуйте советам, описанным выше. Имейте в виду, что здесь используются только английские символы. Кстати, если вы будет использовать ddd, то день недели будет в укороченном варианте из двух букв.


"Горячие" клавиши, комбинации клавиш

"Горячие" клавиши команд в Windows

Нажать | Действие
F1 | Вывести окно помощи
F10 | Активировать меню
ALT+ подчеркнутая буква | Выполнить команду меню
CTRL+F4 | Закрыть текущее окно в программе
ALT+F4 | Закрыть окно или выйти из программы
CTRL+C | Копировать
CTRL+X | Вырезать
CTRL+V | Вставить
CTRL+Z | Отменить
DELETE | Удалить
ALT+Пробел | Вывести системное меню для текущего окна
SHIFT+F10 | Вызов контекстно-зависимого меню
CTRL+ESC | Открыть меню "Пуск"
ALT+TAB | Переключение между задачами
SHIFT+СТРЕЛКА | Выделить символ
SHIFT+CTRL+СТРЕЛКА | Выделить слово
SHIFT+DEL | Вырезать в буфер обмена
CTRL+INS | Скопировать в буфер обмена
SHIFT+INS | Вставить из буфера обмена
PrintScreen | Делает снимок всего экрана и помещает в буфер
ALT+PrintScreen | Делает снимок активного окна и помещает в буфер
CTRL+ALT+DEL | Вызов диспетчера приложений (при двойном нажатии - горячая перезагрузка ПК
Мой компьютер и Проводник
Нажать | Действие
ALT+Стрелка влево | Вернуться назад
ALT+Стрелка вправо | Вернуться вперед
BACKSPACE | Посмотреть папку на уровень выше
CTRL+E или CTRL+F | Открыть окно Поиск
CTRL+H | Открыть окно Журнал
CTRL+I | Открыть окно Избранное
CTRL+R | Обновить окно
F4 | Выпадающий список в адресной строке
Рабочий стол, Мой Компьютер, Проводник
Нажать | Действие
Удерживать CTRL во время перемещения файла | Копировать файл
Удерживать CTRL +SHIFT во время перемещения файла | Создать ярлык
SHIFT+DELETE | Удалить не помещая в корзину
SHIFT+F10 | Контекстное меню выбранного элемента
F2 | Переименовать
F3 | Найти файлы или папку
F5 | Обновить
CTRL + A | Выделить все
ALT+ENTER или ALT+ Двойной щелчок | Посмотреть свойства
Ctrl+D | Удалить выбранный объект
Проводник
Нажать | Действие
Стрелка влево | Прикрыть выделенную папку
Стрелка вправо | Открыть выделенную папку
- (NUM LOCK) | Прикрыть выделенную папку
* (NUM LOCK) | Открыть все подкаталоги в папке
+ (NUM LOCK) | Раскрыть выделенную папку
F6 | Переключение между панелями
Диалоговые окна
Действие | Нажать
Завершить текущее задание | ESC
Нажать на выбранную кнопку или поставить флажок | SPACEBAR
Нажать соответствующую кнопку | ALT+ подчеркнутая буква
Нажать на выбранную кнопку | ENTER
Движение назад по опциям | SHIFT+TAB
Движение назад по закладкам | CTRL+SHIFT+TAB
Движение вперед по опциям | TAB
Движение вперед по закладкам | CTRL+TAB
На уровень выше ( в окнах Открыть и Сохранить Как) | BACKSPACE
Обновить окно загрузки или сохранения | F5
Клавиша WINKEY ( со значком Windows: обычно между Ctrl и Alt)
Нажать | Действие
WIN+TAB | Переключение между кнопками на панели задач
WIN+F | Отобразить поиск файлов
WIN+Ctrl+F | Отобразить поиск компьютеров
WIN+F1 | Вывести помощь по WINDOWS
WIN+R | Отобразить "Выполнить"
WIN | Открыть меню "Пуск"
WIN+BREAK/PAUSE | Вывести апплет "Система"
WIN+E | Открыть "Проводник"
WIN+D | Свернуть или восстановить все окна
Win+L | Быстрая смена сеанса работы пользователя (Windows XP)
Win+U | Вызов Диспетчера служебных программ
В диалогах Открыть или Сохранить как:

F4 - Открыть выпадающий список с деревом папок и устройств (когда выделен какой-либо объект).

При работе с текстом
Нажать | Действие
Ctrl + стрелка вправо | Перемещение курсора на начало следующего слова
Ctrl + стрелка влево | Перемещение курсора на начало предыдущего слова
Ctrl + стрелка вниз | Перемещение курсора на начало следующего параграфа
Ctrl + стрелка вверх | Перемещение курсора на начало предыдущего параграфа
Ctrl + Shift + любая стрелка | Выделение текста
Shift + End | Выделение всей строки с выбранной позиции
Shift + Home | Выделение всей строки до выбранной позиции
Смотри также
Internet Explorer: Комбинации клавиш


Клавиша SHIFT

Если во время перетаскивания файла в мусорную корзину, нажатия на Del или выбора пункта меню "удалить" Вы будете держать нажатой кнопку SHIFT, то файл будет удален, а не помещен в корзину.

Если у вас на компьютере стоит автоматическое распознавание диска CD-ROM, то можно временно его отключить для отдельных дисков. Для этого нажмите и удерживайте клавишу SHIFT при загрузке CD-ROM.

Удерживая клавишу SHIFT при загрузке Windows, вы можете пропустить обработку файлов из Автозагрузки (быстрый перезапуск)

Если у вас в свойствах папки не установлено "Открывать папки в одном и том же окне", то при большой вложенности каталогов у вас может быть открыто очень много окон. Закрывать каждое по-отдельности долго и неинтересно. Если вы хотите закрыть их сразу все, то достаточно, удерживая Shift, закрыть последнее открытое окно с помощью "Х" в верхней правой части окна. Тогда закроются все окна каталогов входящих в путь этой папки.


Раскладка клавиатуры

Если у вас пропал значок раскладки клавиатуры в трее, возможно вы установили Офис ХР. Он имеет свой переключатель раскладок клавиатуры: ctfmon. Чтобы вернуть все как было возможно пойти несколькими путями: - удалить "Альтернативный ввод данных" ("Alternative User Input"). Как это сделать, можно прочитать здесь: http://support.microsoft.com/default.aspx?scid=kb;EN-US;q282599. Затем прописать internat.exe в автозагрузку. - переименовать файл internat.exe в какой-либо другой и прописать его в автозагрузку. - установить, например, программу Punto Switcher который добавляет свою иконку в трей для изменения раскладки клавиатуры. - а проще всего вообще не устанавливать "Альтернативный ввод данных" ("Alternative User Input") при установке Офиса.

Быстрый доступ к меню (в любой программе) - нажимаем "Alt". После этого перемещаемся по меню при помощи клавиш курсора. Указанное свойство может выполнять и "медвежью" услугу, например, если вы пользуетесь для смены языка клавиатуры сочетанием Alt+Shift. Обычно именно такое сочетание стоит по умолчанию при установке Windows. В этом случае, если вы случайно не дожмёте Shift при смене языка, вы попадёте в меню программы, и дальнейшие нажатия клавиш на клавиатуре будут осуществлять навигацию по меню, а не набор текста, как вы, возможно, ожидаете. Зачастую эта навигация может привести в замешательство, и даже повредить документ. Например, если вы нажмёте последовательность клавиш Alt - ф - а (если до этого, скажем, печатали что-то в латинском регистре, а затем захотели допечатать по-русски слово, например, "фазан", но при этом недожали Shift), то Word перейдёт к меню создания нового документа. Комбинация же ф - з после нажатия на "Alt" приведёт вообще к закрытию документа. К счастью, при этом Word спросит у вас о необходимости сохранить изменения...
Выход? Воспользоваться другим сочетанием для смены языка - Ctrl+Shift. Нажатие Ctrl или Shift по отдельности не вызывает в Windows никаких действий. К тому же это удобно при слепом наборе - мизинцем одной руки нажимаем Shift, а другой - одновременно - Ctrl.

Утверждение, что "Нажатие Ctrl или Shift по отдельности не вызывает в Windows никаких действий". То есть да, по отдельности не вызывает, но для переключения языка нужно ведь нажать одновременно, разве нет? И как раз нажимать одновременно Ctrl и Shift плюс стрелки вправо-влево очень часто требуется при редактировании текста в Word, да и вообще в любом текстовом редакторе или процессоре, для выделения фрагментов по словам. Казалось бы, и так плохо, и эдак нехорошо, в обоих случаях есть конфликты с заданными горячими клавишами. Однако ж есть маленький нюанс: в первом случае, страшное может случиться "если вы случайно не дожмёте Shift при смене языка", то есть в случае, если сам юзер немного ошибется. Во втором же случае ошибка, т.е. непреднамеренное переключение раскладки, происходит гарантированно.
Какой из этого вывод? А такой, что сочетание Alt-Shift, при условии, что юзер нажимает его достаточно быстро, ошибок при работе в Windows почти не вызывает. У меня например, за пять лет, что я интенсивно работаю на компьютере, случайный выход в меню программы из-за того, что я пользуюсь Alt-Shift был раза три-четыре всего. В то же время работать с текстами на машинах с установленным сочетанием Ctrl-Shift лично мне становится невозможно, пока я не поменяю его на Alt-Shift. Ну да, конечно, большинство выделяет слова мышью и перетаскивает мышью, для них эта разница незаметна...

Вообще то переключение раскладки клавиатуры (я имею конечно в виду тот случай когда для перключения используется CTRL+SHIFT) не происходит в том случае если вы нажали CTRL+SHIFT и еще какую нибудь стрелочку, так что никаких проблем править текст с помощью клавиатуры нет. Я сам не любитель работать с мышью, но проблем с тем что постоянно происходит переключение языков при правке текста у меня нет.
Но вообще, конечно, тут не о чем спорить, тот кто привык переключать с помощью CTRL+SHIFT не станет переучиваться на ALT+SHIFT (ну и наоборот соответственно), так как в данном случае очень велика сила привычки.
А вообще, я бы рекомендовал пользоваться автоматическими переключателями - очень удобно имеется масса настроек и дополнительных вещей. Хотя опять же надо привыкнуть.

Столкнулся с проблемой: Windows не хочет менять используемую по умолчанию раскладку клавиатуры с помощью диалога "Свойства: Клавиатура".
Способ борьбы: надо поменять в реестре в разделе HKEY_CURRENT_USER\Keyboard Layout\Preload местами значения в строках "1" и "2", должно быть
"1" 00000409
"2" 00000419
Тогда первой будет английская раскладка.


Windows Media Player

Копирование музыки с компакт диска в стандартном проигрывателе WinXP.
Создать .reg файл, скопировать туда следующие строки:

========================================
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MediaPlayer\Settings]

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MediaPlayer\Settings\MP3Encoding]
"LowRate"=dword:0000dac0
"MediumRate"=dword:0000fa00
"MediumHighRate"=dword:0001f400
"HighRate"=dword:0002ee00

========================================
и запустить.
В настройках Windows Media player, установить, в параметрах настройки копирования формат файла MP3.
Только нужен нормальный mp3 кодер, установленный в системе. Без него проигрыватель писать ни чего не будет.


FAR

FAR: Общие советы

Far manager - автоопределение кодировки. Многие удивляются - почему Far даже при включенном свойстве автоопределения кодировки ее не "автоопределяет". Очень просто - их надо установить. Они лежат в папке Far/Addons/Tables - те какие вам нужны, я думаю, Вы сами разберетесь, но Windows-1251 лучше установить в любом случае.

Последние версии FARa позволяют просматривать скрытые общие ресурсы (у которых в конце имени стоит символ $). К таким, в частности, относятся автоматически создаваемые Win2000/XP шаринги с именами C$, D$, ... для администраторского доступа. Чтобы включить эту возможность надо в F9 -> Параметры -> Параметры внешних модулей -> Просмотр сети отметить крестиком пункт Показывать скрытые общие ресурсы. Не забудьте сохранить настройки для следующих запусков.

FAR позволяет просматривать список запущенных на компьютере задач (Ctrl+W), а также переключаться в них (выбрав программу из списка и нажав Enter) и удалять задачи (клавиша Del). При удалении программа будет мгновенно закрыта, при этом, если в ней были какие-то несохраненные данные, они пропадут, так что будьте остарожны с этой возможностью.

При редактировании файла в FARe комбинация клавиш Ctrl+Y удаляет целиком строку на которой находиттся курсор (работает и в некоторых других программах).

Повторно выделить файлы в FARe можно комбинацией клавиш Ctrl+M. Т.е., например, вы скопировали несколько файлов из одного каталога в другой. Если вам надо опять выделить те же файлы, то быстрее и проще нажать указанную комбинацию клавиш, чем выделять их по отдельности заново.

Если Вы используете просмотр процессов в Far'е, то клавиша F3 позволит узнать полное описание любого процесса с приложением названий, размеров и путей всех подключаемых модулей.

Если Вы при редактировании или просмотре файла в FARe нажмете комбинацию клавиш Ctrl+Tab, то сможете перейти в режим просмотра панелей и, например, запустить этот файл на выполнение или открыть другой файл для редактирования. При этом в левом верхнем углу левой панели в квадратных скобках отобразится нечто вида [1+2]. Это означает, что Вы просматриваете один файл, а редактируете два. Очень рекомендую для отладки. А по F12 можно просматривать список экранов и выбирать нужный Вам из меню.

После инсталляции FAR'а рекомендую:

  1. Установить прокрутку в панелях.
  2. Изменить цвет в "Параметры" - "Цвета" - "Диалог" - "Неизмененный текст" со слепого на более зрячий.
  3. Под Windows NT ещё: В Свойствах ярлыка установить ширину экрана=98 - как раз под 12 функциональных клавиш!

FAR позволяет легко менять различные атрибуты файлов (только для чтения, скрытый, системный), а также время создания, модификации и доступа к файлу. Для этого просто установите курсор на нужный файл и нажмите Ctrl+A. Если установить курсор на папку, а затем поменять атрибуты, то они изменятся и у всех вложенных папок и файлов.

Чтобы вставить в FARe полный путь к файлу достаточно нажать Ctrl+F.

Меню выбора диска в FARe (Alt+F1, Alt+F2) может представлять гораздо более обширную информацию о дисках компьютера. Чтобы посмотреть различные варианты, нажимайте клавиши Ctrl+1 ... Ctrl+8 в меню выбора диска. Попробуйте поэкспериментировать самостоятельно, какая детализация информации вам больше нравится. Некоторые варианты могут замедлять время появления меню на экране. Не забудьте сохранить настройки.

Две полезные комбинации клавиш для FARa: Ctrl+PgUp и Ctrl+PgDown позволяют перемещаться по каталогам на один уровень вверх и вниз соответственно. Это бывает полезно в том случае, если у вас что-либо набрано в коммандной строке и вы не хотите чтобы этот текст пропал. Ctrl+PgDown позволяет, к тому же, заходить внутрь самораспаковывающегося архива.

Чтобы быстро записать макрос в Far'е можно:
- нажать клавиши "Ctrl"+"."
- вести необходимую комбинацию клавиш
- повторно нажать "Ctrl"+"."
- выбрать хот-кей.

Если в любом диалоговом окне FARa (копирование файлов, переименование, создание и т.п.) нажать комбинацию клавиш Shift+Enter, то в него будет добавлено имя файла, выделенного курсором в окне программы.

Очень удобным инструментом в FARe является временная панель. Ее можно вывести на экран либо нажав F11, либо выбрав соответствующий пункт в выборе диска по Alt+F1(F2), либо выбрав "Панель" в окне поиска (Alt+F7). В последнем случае на временную панель будут выведены все найденные файлы. Если копировать на нее какие-то файлы, то туда будут перенесены просто ссылки на них с информацией о размере в байтах. Приведу несколько примеров использования: удобно работать с файлами, разбросанными по разным каталогам, без постоянного поиска и перехода к ним; можно искать файлы по маске (напр. *.tmp ...), а потом удалить их все разом или перенести куда-то (очень поможет, если они разбросаны по куче каталогов на всем диске).

Чтобы из FAR'а открыть текущий каталог в Explorer'е, вовсе не нужно писать "start ." - достаточно нажать "." и "Shift-Enter" (то есть "запустить точку в новом окне").

Чтобы открыть ДОСовскую задачу через FAR в новом окне, надо запускать ее комбинацией клавиш Shift+Enter. Это позволяет открыть программу не занимая окна FARa. Если программу надо запустить с параметрами, например, regview system.dat, то после набора этого в коммандной строке, также нажмите SHift+Enter.

Если нажать комбинацию Ctrl+\ то вы сразу перейдете в корневой каталог текущего диска (это кстати касается не только Far-a, но и Нортона и прочиих подобных "коммандеров")

Бывает, что надо быстро перевести текстовый файл из DOS-кодировки в Windows или наоборот. Для этих целей удобно воспользоваться FAR'ом. Откройте файл на редактирование, выделите весь текст (Ctrl+A), удалите в буфер обмена (Ctrl+X), поменяйте кодировку (F8), вставьте текст из буфера (Ctrl+V). Все, кодировка изменилась, а на все ушло буквально пара секунд времени.

Удаление файлов и папок в Far Manager. F8 и Shift-Del удаляют все выбранные файлы, Shift-F8 - только файл под курсором. Shift-Del всегда удаляет файлы, не используя Корзину (Recycle Bin). Сочетание Alt-Del уничтожает файлы и папки по хитрому. Перед удалением файл перезаписывается нулями, усекается до нулевой длины и переименовывается во временное имя.

В FARe есть способ быстро выделить или снять выделение со всех файлов в каталоге, имеющих одинаковое расширение. Для этого надо установить курсор на любой файл с нужным вам расширением и нажать комбинацию клавиш Ctrl+Gray"+" для выделения и Ctrl+Gray"-" для снятия выделения.

Если, при редактировании файла в FARe вам надо выделить прямоугольный фрагмент текста (например, какую-то колонку в таблице), нажмите и удерживайте клавиши Shift+Alt и с помощью клавиш управления курсором выделите нужную вам область. Теперь если его скопировать в буфер обмена и вставить в другое место, то он так и добавится в виде прямоугольного фрагмента.

В FARe можно изменять ширину панелей на экране. Для этого удерживая Ctrl нажимайте клавиши "стрелка вправо" или "стрелка влево". При этом ширина одной панели будет увеличиваться, а другой - уменьшаться. Это позволит просматривать имена более длинных файлов.

Если имя длинного файла не помещается целиком в колонке панели FARa, вы можете посмотреть его окончание нажав и удерживая Alt и "стрелку вправо" на клавиатуре управления курсором.

Редактировал эту страничку и случайно натолкнулся еще на одну интересную комбинацию клавиш FARa: если при редактировании файла нажать Shift+Enter, то, начиная с позиции курсора, в текст будет добавлено имя редактируемого файла.

Комбинация клавиш Ctrl+[ позволяет скинуть в командную строку полный путь к каталогу, открытому в левой панели, клавиши Ctrl+] - путь каталога в правой панели. Частенько бывает необходимо указать где-то полный путь файла, тогда нажимаете Ctrl+[ (или Ctrl+] - в зависимости от того в какой панели этот файл), затем Ctrl+Enter, чтобы скинуть имя этого файла и Ctrl+Insert, чтобы поместить содержимое командной строки в буфер обмена. Получается очень быстро и удобно.

Если вы заметили, то в FARe выделенный текст так просто удалить по клавише Delete не удается (будет удален только символ над курсором). Чтобы удалить выделенный фрагмент текста нажмите Ctrl+D, чтобы переместить его в буфер обмена нажмите Shift+Delete. Комбинация клавиш Ctrl+Delete позволяет удалить текст начиная от курсора до конца слова, Ctrl+Backspace - от начала слова до курсора.

Если в FARe нажать комбинацию клавиш Alt+Insert, то вы сможете переместить курсор в любое место окна (курсор изменит вид). Затем удерживая Shift можно выделить какую-то область на экране и нажав Enter скопировать ее в буфер обмена. Эта возможность может быть очень полезна если вам надо скопировать прямоугольный кусок текста. Таким образом можно копировать даже внешний вид оболочки FARa.

В FARe можно открыть текущую папку в Windows'овском окне. Для этого наберите в командной строке "start ." (конечно, без кавычек). Между "start" и "." обязательно должен быть пробел. Удобно добавить эту команду в пользовательское меню на F2 - тогда открыть окно можно одним нажатием клавиши.

Если установить в Настройке интерфейса (F9->Параметры->Настройки интерфейса) пункт "История в строках ввода диалогов", то при выполнении таких действий как создание файла (Shift+F4), копирование (F5), переименование (F6) и т.п. можно нажать комбинацию клавиш Ctrl+Стрелка вниз и будет выведена история по последним 16 соответствующим действиям.

В FARe есть возможность рисовать линии в текстовом файле. Для этого, когда вы находитесь в режиме редактирования, нажмите F11 и выбирите соответствующий пункт. Теперь, если удерживать нажатым Shift, можно рисовать с помощью клавиш перемещения курсора. Также можно выравнивать блоки текста (конечно, где это возможно). Выделите блок текста, нажмите F11 и выбирите первый пункт меню. Вы можете настроить длину строки, выравнивание правой границы и кое-что еще.

В FARe есть возможность установить ссылки на папки (до 10 штук). Для этого зайдите в папку, ссылку на которую вы хотите установить, нажмите F9, Команды->Ссылки на папки. Выбирите нужную комбинацию клавиш и нажмите Insert. Теперь, когда вы работете в FARe, вы можете в любой момент нажать правый Ctrl и цифровую клавишу, заданную вами в настройке, чтобы на активной панели открылась ассоциированная с этой комбинацией папка.

Если в Fare выбрать F11 -> Process List (список процессов), то можно убить любой процесс. Даже kernel32 (Он действительно умирает вместе со всем остальным).

В FARe есть одна очень полезная функция: Расширенное сравнение. С помощью нее можно побайтово сравнить файлы, причем они могут быть вложены в каталоги. Для чего это нужно? Например, при записи на CD бывают случаи, когда визуально файлы переписались нормально, но в структуре файла допущена ошибка (достаточно одного неверного символа), и файл может не запуститься. Вот в этот момент и пригодится расширенное сравнение. Вызвать его можно с помощью клавиши F11.


Интернет: Общие советы

Общие советы

Если у тебя есть домашняя страничка, и ты не хочешь, чтобы поисковые роботы индексировали твою страничку с секретной информацией, то используй следующий тег: <META name="robots" content="none">
Теперь поисковики не будут замечать вашу страницу.

Даже не имея ICQ, вы мoжeте пocлaть сообщение на ICQ-пейджep своему другу: зайдите нa aдpec http://wwp.mirabilis.com/****** (вмecтo звёздoчeк надо указать нужный ICQ-нoмep (UIN)) или отправьте e-mail нa aдpec *****@pager.mirabilis.com

Если вы хотите, чтобы на странице около вашего номера Аськи был показатель присутствия в сети, то используйте код:
<img alt="ICQ status" src="http://online.icq.com/scripts/online.dll?icq=UIN&img=N"/>
Вместо UIN нужно подставить ваш номер. N - вариант индикатора. Их что-то около 17-ти (1-17)

Если в Internet Explorer, в диалоге "Загрузка файла" при ответе на вопрос "Открыть файл"/"Сохранить на диске" вы случайно убрали галочку "Всегда задавать этот вопрос, открывая такие файлы", то можете вернуть прежнее поведение. Откройте Проводник - Сервис-Свойства папки-вкладка Типы файлов. Найдите тип файла ZIP и нажав кнопку "Дополнительно", поставьте флажок "Подтверждать открытие после загрузки.

В интернете есть очень удобная служба, которая позволяет заказывать html-страницы, включая графику, подписываться на рассылку страниц и осуществлять поиск в WWW. Доставку других файлов ни с http, ни с ftp-серверов она не обеспечивает. Для начала можно послать пустое письмо на адрес www@web2mail.com, и нам придёт файл помощи на английском языке в виде html-страницы. Далее на тот же адрес посылаем письмо с командой в поле Тема (Subject). Для заказа страницы без графики команда представляет собой лишь адрес страницы. Писать приставку http:// необязательно. Проще не придумаешь. Для заказа страницы со всей присущей ей графикой дописываем к адресу два слова - with images:
http://www.webhowto.ru/reg/reg_nd01.shtml with images
Очень удобно - все ссылки на получаемой странице переделываются таким образом, чтобы при нажатии на них почтовый клиент создавал новое письмо для службы web2mail уже с командой в поле Тема для заказа этой страницы. Остаётся только отправить созданное письмо! Абсолютно новый вид услуг - подписка на страницы. К примеру, мы хотим еженедельно получать какую-то страницу, чтобы отслеживать новую информацию на ней. Для этого перед адресом страницы пишем слово subscribe, а после - weekly: subscribe http://www.webhowto.ru/reg/reg_nd01.shtml weekly Для ежедневного получения вместо weekly надо указать daily, для ежемесячного - monthly. Причём сразу можно заказать сколько угодно страниц, перечислив их адреса через пробел. Ещё один плюс: служба не будет слать страницу, на которую подписались, если на ней не произошли изменения со времени предыдущей рассылки.
Ну и под конец - поиск. Всё так же просто, как и выше. Создаём письмо на уже известный адрес, в Теме пишем команду search и нужное словосочетание, например: search Billy Gates. Убедительная просьба: не забивайте службу сразу пятью заказами, дождитесь прихода предыдущих. Именно из-за жадности людей такие службы и сидят в дауне, не отвечая несколько дней, или вовсе закрываются. Поэтому, давайте хоть немного думать о других и о дне завтрашнем.

Ярлыки на интернет-сайты и письма (*.url) представляют собой текстовые файлы с расширением URL. Их можно создать в простом блокноте. Вот пример:

[InternetShortcut]
URL=http://www.winhowto.ru/
IconIndex=1

Или

[InternetShortcut]
URL=mailto:terminator2@mail.ru
IconIndex=1

Или

[InternetShortcut]
URL=file://C:\Windows\win.ini

Первый пример открывает браузер по умолчанию и начинает загрузку сайта, второй выводит окно нового письма, третий запускает ваши файлы.

Вы можете открыть установленный по умолчанию почтовый клиент с уже заполненным адресом, просто запустив из коммандной строки (Windows Start/Run, или Win+R, или из командной строки Windows Commander) следующую строку:
mailto:
Можно так же сразу же из коммандной строки заполнить большинство полей в email (все поля опционны, вы можете заполнять только те что нужны):
mailto:nevzorov@yahoo.com?subject=Regarding+your+advice&Body=Is+is+working+great&CC=vnevzorov@trondent.com
Обратите внимание, что пробелы должны быть заменены на знак "+"
Такой же формат можно использовать и на web страницах в гиперлинках.

Иногда мне жалуются на то, что свежескачанные архивные файлы моих программ не распаковываются, выдавая сообщение о поврежденном архиве. Когда я пытаюсь скачать и разархивировать эти файлы, все оказывается нормально. Зачастую, такие проблемы возникают, если в полном имени файла присутствуют русские буквы или длинные имена. В этом случае надо попробовать перенести его в другой каталог, избавленный от этих недостатков.

Возможно, многие это знают, но чтобы в Аське отправить набранное сообщение достаточно нажать Ctrl+Enter. Намного ускоряет работу :).

Откройте папку Удаленный доступ к сети, вызовите свойства соеденения с провайдером, перейдите во вкладку Тип сервера и уберите флажок Войти в сеть. После этого соединитесь с провайдером и убедитесь, что все работает нормально. Большинство провайдеров не используют режим входа в сеть, а период ожидания может занять до 60 секунд, поэтому, скорее всего, процесс подключения к Интернету будет происходить быстрее.


Internet Explorer: Общие советы

Можно настроить советы, которые отображаются внизу окна Internet Explorer, когда вы выбираете в меню Справка-Полезный совет. Данные советы хранятся в файле tip.htm папки Windows\Web. Все советы находятся в отдельном слое с идентификатором от id="Tip 1" до id="Tip 74". Вы можете заменить эти советы на анекдоты, афоризмы, собственный советы или добавить новые (id="Tip 75" и т.д.). Кстати, желтая лампочка, отображаемая слева от советов, хранится в файле Tips.gif - вы ее тоже можете заменить.

Нестандартная иконка вашего сайта в Избранном.
Увидев подобную иконку у себя в "Избранном", пользователь запомнит ваш сайт. Как сделать подобную примочку у себя на сайте?
Прежде всего нужно эту иконку нарисовать. А размером она должна быть ровно 16х16 пикселей и иметь 16 цветов, так что не особо "развлекайтесь". Расширение она должна иметь .ico Вес иконки не должен превышать 1,046 кб. Но и это еще не все, название иконки должно быть favicon.ico. Заливаете себе иконку на сервак в корневую директорию и с этих пор, Internet Explorer сам найдет эту иконку в случае, если ваш сайт удостоится попасть в "Избранное". Хотелось бы заметить, что не все сервера изначально "понимают" эту иконку. Для того, чтобы не возникало проблем, убедитесь, что настройки сервера позволяют пользоваться favicon.ico
Если возникают проблемы, иконку можно подгрузить и принудительно. Для этого между тегами вставьте следующий код, который явным образом укажет браузеру на иконку. Но эта операция, как правило не требуется и является необязательной.
<LINK REL="SHORTCUT ICON" HREF="http:/ваш_сайт.ru/favicon.ico">
Все, отныне ваша иконка будет красоваться в папке "Избранное" напротив названия вашего сайта у пользователей, которые, соответственно, добавят сайт себе на заметку в "Избранное" и, возможно, забыли бы о нем. Ан нет. Теперь не забудут. Иконка эффектно отличается на фоне стандартных картинок Internet Explorer`а и это еще один повод напомнить пользователю о своем сайте...
Дополнение к совету: Кстати, вы сами можете назначать значки у себя в Избранном. При большом количестве закладок нестандартные значки позволят немного упорядочить ваш список сайтов. Откройте меню Избранное - выберите нужную вам закладку и правой кнопкой откройте Свойства. В появившемся окне нажимаете кнопку Сменить значок и выбираете любой по вкусу.

При загрузке страницы с ошибкой Internet Explorer в строке состояния в левом нижнем углу окна отображает значок ошибки и текст, предупреждающий об этом. Чтобы узнать какая именно ошибка произошла и где, надо дважды шелкнуть левой кнопкой мыши по этому значку ошибки. Появится сообщение о типе ошибки и строке, где она произошла. Если вы хотите, чтобы такое сообщение появлялось автоматически при каждой обнаруженной ошибке, надо в настройках браузера (Сервис->Свойства обозревателя->Дополнительно) отметить галочкой пункт: "Показывать уведомление о каждой ошибке сценария"

Можно сделать так, чтобы Windows блокировала баннеры. Для этого нужно в файл C:\WINDOWS\system32\drivers\etc\hosts (без расширения) внести список известных баннерных сетей примерно такого вида:
127.0.0.1 banner.kiev.ua
127.0.0.1 banner.list.ru
127.0.0.1 banner.ricor.ru
127.0.0.1 banner.trifle.net
- то есть каждой баннерной сети принудительно назначить адрес 127.0.0.1, принадлежащий вашему собственному компьютеру. При этом, встретив на веб-страничке ссылку, например, на banner.list.ru, ваш браузер попытается загрузить ее с вашего же компьютера, а поскольку веб-сервера на нем не наблюдается, то баннер попросту будет отсечен и интернет-запросов на него уходить не будет. Соответственно, не будет и качаться из Сети громоздкий графический файл. Правила и примеры составления файла hosts вы найдете в файле C:\Windows\hosts.sam, который находится на диске только в учебных целях и системой не обрабатывается. В интернете можно найти уже готовые файлы hosts с уже внесенными в него списком баннерных сетей.
Кроме того, файл hosts можно использовать и для ускорения интернета. Обычная схема обращения к определенному интернет-серверу по его имени следующая:
1. Определение IP-адреса через DNS
2. Установление TCP-соединения с данным IP-адресом и стандартным для данного сервиса (http, ftp, smtp...) номером порта
3. Собственно работа
Обращение к DNS может занимать разное время - это зависит от многих факторов. И все-таки, если Вы работаете большей частью с одними и теми же хостами (поисковые машины, интернет-библиотеки и т.п.), то время работы можно сократить за счет обращения к DNS. Для этого Вам нужно узнать IP-адреса Ваших любимых серверов и записать их в hosts-файл. Надо сказать, что такой подход является единственным при обращении к многим WWW-серверам: прямое обращение по IP-адресу может не получиться, и вот почему. Целый ряд WWW-серверов использует так называемые "виртуальные хосты", т.е. фактически по одному IP-адресу может находиться несколько (часто очень много) как-бы независимых веб-серверов. Эти виртуальные сервера, как правило, отличаются доменами третьего (более редко-второго) уровня. По полю Host заголовка HTTP-запроса веб-сервер определяет, к какому сайту идет обращение, и ведет себя соответственно. Если, скажем, сайты www.aaa.com, www.bbb.com и www.ccc.com имеют один IP-адрес 172.16.1.1, то при обращении по имени www.aaa.com сервер получит поле Host: myhost.aaa и поведет себя как сервер www.aaa.com. При обращении по IP-адресу сервер получит Host: 172.16.1.1 При этом он либо поведет себя как сервер "по умолчанию", либо выдаст сообщение об ошибке. Если же в файле hosts записано 172.16.1.1 www.aaa.com и пользователь обращается по имени, то сервер получит нормальное поле Host. Узнать IP-адреса можно разными путями. Можно использовать специальные программы (DNS Resolver), специально предназначенные для обращения к DNS. Можно использовать ответы программы ping, входящей в поставку Windows. Для этого нужно выполнить командную строчку:
ping <имя хоста>
В ответе программы будут строчки вида:
Reply from (ip-адрес этого хоста);
Можно также воспользоваться IE, дав URL с определяемым именем хоста. В строке состояния сначала появится Поиск узла..., затем - Соединение с узлом IP-адрес. Просто запишите его.

В последних версиях Internet Explorer появилась функция экспорта и импорта списка Избранное (Favorites). Для этого в меню "Файл" Internet Explorer достаточно выбрать команду "Импорт и экспорт" - запустится очень простой мастер, который и осуществит генерацию веб-страницы, содержащий ссылки из Избранного

Если очень хочется посмотреть исходный текст web-страницы просто добавьте "view-source:" перед URL. Например: view-source:http://webhowto.ru/reg/nd_add.php Откроется notepad (или чего у вас там есть) с исходным текстом этой web-страницы. Иногда даже очень помогает :-)

Определение даты последней модификации просматриваемой страницы. Если в поле адреса ввести текст: javascript:alert(document.lastModified) то появится окно в котором будет написано дата последней модификации страницы. Для удобства частого использования введенный адрес можно перетащить на панель ссылок.

Если при щелчке по ссылке в Internet Explorer'e удерживать нажатой клавишу Shift, то ссылка откроется в новом окне.

Отключение графики в браузере приводит к ускорению загрузки страниц, если у вас модем, и к существенному уменьшению траффика, если у вас локалка...

Щелчoк на кнопке максимизации (или двойной щелчoк на заголовке окна) при нажатом Ctrl раскрывает на полный экран Internet Explorer (так же как и клавиша F11).

Если у вас уже запущен один IE, второй может запускаться в маленьком размере (не на весь экран). Чтобы избавиться от этого эффекта, расширьте его окошко на весь экран, а затем закройте. При последующих запусках он будет открываться по-человечески. Это касается и Netscape.

Если во время работы в Internet Explorer'e зажать клавишу Ctrl и вращать скроллинговое колесико у мыши, то будет изменяться размер шрифта текста на страницах. Если удерживать Shift и вращать колесико, то можно перемещаться по списку просмотренных страниц в History браузера. Перемещаться по этому списку можно также удерживая Alt и нажимая клавиши стрелок "вправо", "влево". Стрелка влево - предыдущая страница, вправо - следующая.


Internet Explorer: Стартовая страница

Стартовая страница

Если вас замучали сайты, меняющие стартовую страницу в Internet Explorer, то создайте файл startpage.js в любом текстовом редакторе (напр. Блокнот), скопируйте туда этот код:

var WSHShell = WScript.CreateObject("WScript.Shell");
//Делаем задержку 10 секунд на случай если
//паразитный сайт добавил что-то в автозагрузку
WScript.Sleep(10000);
//Проверяем что у нас в стартовой странице
StartPage = WSHShell.RegRead("HKCU\\SOFTWARE\\Microsoft\\Internet Explorer\\Main\\Start Page");
//И если там не то, что мы задумали, то меняем на свое
if (StartPage!="http://www.webhowto.ru/reg") {
  WSHShell.RegWrite("HKCU\\SOFTWARE\\Microsoft\\Internet Explorer\\Main\\Start Page",
  "http://www.webhowto.ru/reg");
}
в строке if (StartPage!="http://www.webhowto.ru/reg") и в следующей поменяйте адрес сайта на нужный вам и добавьте этот файл в автозагрузку в раздел: HKCU\Software \Microsoft\ Windows\ Current Version\Run.

Предварительно убедитесь что в каталоге Windows у вас есть файл wscript.exe (если вы пользуетесь Win98/2000/XP, то он у вас скорее всего есть). Теперь при старте системы, если начальная страница IE отличается от заданной вами, она будет заменена на ту, что вы настроили. Ну, а если вам захочется узнать подробнее, как все это работает, почитайте статью о Windows Script Host (совет взят именно оттуда).

Зачастую некоторые веб-сайты имеют наглость менять вашу стартовую страницу, потом при следующем старте открывается "миллион" окон и иногда даже не удается добраться до установок браузера до того как вся винда рухнет. Может кому покажеться выгодным моя мелкая хитрость. Уменя создан текстовый файл прямо на десктопе с расширением ".reg" следующего содержания:

REGEDIT4

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
"Start Page"="http://www.webhowto.ru/"
После работы с интернетом, особенно если посещались сомнительные места, я просто запускаю этот файл...


Internet Explorer: Командная строка

Параметры командной строки

Для Internet Explorer существуют несколько ключей. Для их использования необходимо запустить файл iexplore.exe из командной строки с указанием нужного параметра (например, используя строку "Выполнить" меню "Пуск") либо прописать требуемый параметр в свойствах специально созданного ярлыка к браузеру (получится примерно следующее:
"C:\ Program Files\ Internet Explorer\iexplore.exe" -nohome).

Список ключей

  • -channelband - Internet Explorer будет запущен в качестве специальной панели каналов на Рабочем столе текущего пользователя. Данная опция работает только при выключенном активном Рабочем столе (Active Desktop)
  • -e - Internet Explorer будет запущен в двухпанельном режиме Проводника (дерево папок слева, содержание справа)
  • -new - новое окно программы Internet Explorer будет запущено как отдельный процесс;
  • -nohome - при запуске Internet Explorer не будет открывать никаких веб-страниц. При этом скорость загрузки программы гораздо быстрее, чем если даже стоит в стартовой странице about: blank
  • -k - запуск браузера в полноэкранном режиме (Kiosk mode);
  • -slf - при запуске открывается домашняя страница пользователя;
  • -embedding - Запускает Web browser control без показа странички
Можно в командной строке указать и URL-адрес страницы, которую требуется открыть: iexplore -k www.winhowto.ru


Internet Explorer: Комбинации клавиш

Горячие клавиши для просмотра и навигации

Часть горячих клавиш работает и в Проводнике, т.к. сама система очень тесно связана с iexplorer.exe
Нажать | Действие
F1 | Вывести окно помощи IE
F5 | Обновить страницу
F11 | Переключает в полноэкранный режим и обратно
ENTER | Переход по выбранной ссылке
SHIFT + F10 | Контекстное меню для ссылки или страницы
BACKSPACE | Переход на предыдущую страницу
ALT + Стрелка влево | Переход на предыдущую страницу (Аналогично BACKSPACE)
ALT + Стрелка вправо | Переход на следующую страницу
ALT + Home | Переход на домашнюю страницу
Стрелка вверх | Скроллинг вверх
Стрелка вниз | Скроллинг вниз
PAGE UP или SHIFT+Пробел | Скроллинг вверх на одну страницу
PAGE DOWN или Пробел | Скроллинг вниз на одну страницу
HOME | В начало документа
END | В конец документа
ESC | Прервать загрузку страницы
CTRL+E | Открыть окно Поиск
CTRL+F | Открыть диалоговое окно Найти на этой странице
CTRL+H | Открыть окно Журнал
CTRL+I | Открыть окно Избранное
CTRL+L или CTRL+O | Открыть диалоговое окно Открыть
CTRL+N | Открыть новое окно
CTRL+P | Печать текущего документа
CTRL+R | Обновить страницу (аналогично F5)
CTRL+S | Сохранить текущую страницу
CTRL+W | Закрыть окно

Горячие клавиши для Адресной строки
Нажать | Действие
F4 | Показать список записей Адресной строки
CTRL+Стрелка влево | В Адресной строке курсор перемещается к следующему логическому символу прерывания (. или /)
CTRL+Стрелка вправо | В Адресной строке курсор перемещается к следующему логическому символу прерывания (. или /)
CTRL+ENTER | Добавляет http://www. в начало и .com в конец текста, напечатанного в Адресной строке. Например, если вам надо набрать "http://www.google.com", введите "google" и нажмите Ctrl+Enter.
Горячие клавиши для работы с Избранным
Нажать | Действие
CTRL+D | Добавить текущую страницу в Избранное
CTRL+B | Открывает диалоговое окно Упорядочить Избранное

Если при щелчке по ссылке в Internet Explorer удерживать нажатой клавишу Shift, то ссылка откроется в новом окне.

Щелчoк на кнопке максимизации (или двойной щелчoк на заголовке окна) при нажатом Ctrl раскрывает на полный экран Internet Explorer (так же как и клавиша F11).

Если во время работы в Internet Explorer'e зажать клавишу Ctrl и вращать скроллинговое колесико у мыши, то будет изменяться размер шрифта текста на страницах. Если удерживать Shift и вращать колесико, то можно перемещаться по списку просмотренных страниц в History браузера. Перемещаться по этому списку можно также удерживая Alt и нажимая клавиши стрелок "вправо", "влево". Стрелка влево - предыдущая страница, вправо - следующая.


Internet Explorer: Разное

Визуальный редактор

Оказывается Internet Explorer очень просто можно превратить в простейший визуальный (!!!) редактор HTML. Это очень удобно, когда в страничке нужно изменить одну-две буквы, а полноценного (и потому монстрообразного !) редактора HTML под рукой не оказалось. Итак: В реестре HKEY_CURRENT_USER\ SOFTWARE\ Microsoft \Internet Explorer \MenuExt создать раздел с имененм "&Режим редактирования" и присвоить параметру по умолчанию строку C:\Windows\EDIT_IE.HTM (или любой другой путь и файл). В этом же разделе создайте новый DWORD-параметр под названием Contexts и измените его значение на 1. В указанной выше папке создать файл EDIT_IE.HTM со следующим содержимым:
<script language="JavaScript"defer>
var parentwin=external.menuArguments;
var doc=parentwin.document;
doc.designMode="On";
</script>
После загрузки HTML в IE по правой кнопке мыши выбрать Режим редактирования. Чтобы выйти из него, выбрать Вид обзора. Чтобы создать документ с нуля - загрузить about:blank и войти в режим редактирования. Конечно, отсутствует панель инструментов, но начертание помеченного фрагмента текста можно изменить с помощью стандартных комбинаций клавиш CTRL-B, CTRL-I. Может работают и другие комбинации - не проверял. Доступны удаление и вставка рисунков.
© 2002 И. Чеботарев, А.Климов
http://www.webhowto.ru/reg
http://winchanger.narod.ru


Outlook Express: Общие

При плохой связи в работе с Outlook Express появляются сообщения: "Ваш сервер не ответил в течение 60 секунд. Подождать ответа еще 60 секунд?" Можно увеличить время ожидания.
В меню "Сервис" выберите "Учетные записи..." и на вкладке "Почта" выберите нужную запись и жмите кнопку "Свойства". Выберите вкладку "Дополнительно" и там, используя ползунок "Время ожидания сервера", установите нужный интервал.

Сохранение сообщений в Outlook Express.
Для сохранения ваших сообщений нужно сделать следующее: Зайти в папку "Windows\Application Data\Identities\набор цифр\Microsoft\Outlook Express\" и скопировать все файлы куда нибудь для дальнейшего их восстановления.

Если вы часто переустанавливаете систему (Win 9x), то вам приходится каждый раз вводить учетные записи в Outlook Express. Воспользуйтесь встроенной стандартной функцией? В меню Сервис - Учетные записи - вкладка Почта, отмечаем учетную запись и жмем кнопку Экспорт для сохранения в файле, для ввода учетной записи на место после переустановки системы - Импорт.

Сохранение правил для сообщений в Outlook Express. Правила сортировки входящих почтовых сообщений Outlook Express хранит в реестре, в ветви HKEY_CURRENT_USER\Identities\набор цифр\Software\Microsoft\Outlook Express\5.0\Rules\Mail. Экспортировав ее в текстовый файл с расширением reg и сохранив его, можно будет после переинсталляции Windows и Outlook Express запустить его, восстановив сразу все правила.

Если запускать Оутлук с параметром /news, то он будет работать только с группами новостей (очень удобно для пользователей TheBat).


The Bat!

The Bat!: Общие

Если The Bat! запустить с параметром /CHECKALL, то The Bat! проверит почту всех незапароленных ящиков, после чего закроется

Открыв русифицированный TheBat.LNG hex-редактором, можно вместо стандартных надписей написать что-нибудь своё! А если вы забыли пароль который ставили на аккаунт в The Bat!, то просто откройте ACCOUNT.CFG находящийся в соответствующей дириктории hex-редактором и увидите свой пароль! :)

Если при старте The Bat! в командной строке (или в свойствах ярлыка) добавить /NOLOGO, то при запуске не будет появляться логотип программы. Это позволит чуть-чуть уменьшить время загрузки

The Bat! при удалении писем не уничтожает их физически, а просто помечает как удаленные и не выводит их в общем списке писем (посмотреть удаленные письма можно, выбрав пункт меню "Папка"->"Посмотреть удаленные письма"). Со временем, при интенсивной переписке, такие письма начинают занимать очень много места (файл, где они хранятся, находится в каталоге Бата\Mail\[имя ящика]\[имя папки]\messages.tbb). Для уничтожения этого мусора рекомендуется иногда сжимать папки ("Папка"->"Сжать все папки"). При этом письма, помеченные как удаленные, будут стерты окончательно.

Достаточно просто перетащить нужные файлы в окно The Bat! и они будут автоматически присоеденены к отправляемому вами письму.


OFFICE: Общие советы

  1. Если вы хотите чтобы интерфейс Офиса 2000/ХР был как у предыдущих версий (т.е. чтобы были видны все пункты меню, а не только недавно использованные), надо зайти в Вид->Панели инструментов->Настройка->Параметры и убрать галочку у пункта "В меню сначала отображаются последние использованные команды".
  2. Для нормальной работы OfficeXP не удаляйте файл Data.bak чистильщиком в каталоге C:\Windows\AllUsers\Application Data\Microsoft\Office\Data.
  3. Для того чтобы быстро добраться до Настройки: или других панелей кликните правой кнопкой мышки на меню или кнопках и выберите то что вам нужно.
  4. Для быстрой загрузки Word'а можно назначить комбинацию клавиш. В меню Пуск находим ярлык которым запускаем Word, нажимаем на ярлыке правой кнопкой мыши и выбираем СВОЙСТВО, назначаем комбинацию клавиш. Впрочем, это справедливо для любых ярлыков.
  5. При поиске файлов, содержащих заданный текст, Windows 95/98 не находит текст, записанный в кодировке Юникод. В этом формате обычно сохраняются документы программ семейства Office 97 (кроме программы Access, которая использует этот формат, начиная с Access 2000) и некоторых других. Вместо средств Windows 95/98 в таких случаях следует использовать средства поиска файлов, входящие в состав семейства Office (в окне "Открытие файла" щелкните на кнопке "Отбор" и задайте необходимые параметры поиска).
  6. После установки MS Office рекомендую удалять из автозагрузки программы Быстрый запуск MS Office и Быстрый поиск файлов.


EXCEL: Общие советы

Не все знают, как удобнее в Excel переместиться на нужную ячейку! Необязательно курсор мыши тянуть до нужного вам столбца или строки. Можно всего лишь в поле имени (поле слева от строки формул, в котором отображается имя выбранной ячейки) прописать букву столбца и номер строки. Вот и все перед вами ваша ячейка.

Наверное, многие знают, что для того чтобы автоматически заполнить столбец ячеек одним и тем же содержимым, достаточно набрать его в первой ячейке, а затем, подведя курсор мыши к парвому нижнему углу ячейки и удерживая левую кнопку, выделить нужную область. А вот для того чтобы заполнить эту область следующими по-порядку цифрами (напр. 1, 2, 3, ...), в первой ячейке набрать первую цифру из этого ряда и выделять область удерживая "CTRL".

Быстро вставить несколько ячеек в Excel можно, если пометить ячейку, после которой надо вставить новые ячейки, поместить курсор мыши над правым нижним углом ячейки, нажать Shift (курсор поменяет вид) и, удерживая его, зажав левую кнопку мыши растянуть рамку на столько ячеек, сколько надо вставить.

В ячейке Excel может находиться более одной строки текста - можно вручную вставлять "разрыв строки" или абзаца. После нажатия Alt+Enter курсор внутри ячейки переносится на следующую строку. Процесс переноса на следующую строку можно автоматизировать, если отметить пункт "Переносить по словам" в закладке "Выравнивание" (Формат-Ячейки).

В Excel'e есть возможность защитить от изменения отдельный лист. Для этого надо выбрать пункт меню Сервис->Защита->Защитить лист. Если вы хотите подредактировать его, то защиту надо снять с помощью пункта меню Сервис->Защита->Снять защиту.

Для расчета формулы в какой-то ячейке Excel не обязательно перед формулой ставить знак "=". Вместо него можно поставить "+". При этом в формуле можно также использовать значения каких-то ячеек. Это может быть удобно для тех, кто осуществляет набор данных на малой цифровой клавиатуре.

Для того чтобы быстро просуммировать значение нескольких ячеек, идущих подряд в строке или столбце (без лишних движений мышкой, а только с клавиатуры), в ячейке, где нужно значение суммы, нажать "ALT"+"=" и Enter. При этом данные для суммирования будут браться из ячеек, идущих подряд, выше или левее той, в которой вы находитесь.


EXCEL: Горячие клавиши

Горячие клавиши и комбинации клавиш

Некоторые горячие клавиши для Excel, позволяющие более комфортно перемещаться по листу, между листами и рабочими книгами:

  • PAGE DOWN - переход на один экран вниз;
  • PAGE UP - переход на один экран вверх;
  • ALT+PAGE DOWN - смещение на один экран вправо;
  • ALT+PAGE UP - смещение на один экран влево;
  • CTRL+END - переход в последнюю ячейку на листе;
  • CTRL+PAGE DOWN - переход на следующий лист;
  • CTRL+PAGE UP - переход на предыдущий лист;
  • CTRL+F6 - переход в следующую рабочую книгу или окно (это так же справедливо и для Word).


EXCEL: Пасхальное яйцо

В Excel2K гонки:
1. Запустите Excel 2000
2. Выберите "Save as web page" (сохранить как Web-страница) из меню File.
3. Выберите "Save: Selection: Sheet" (Сохранить выделенный лист)
4. Отметьте галочку "Add interactivity" (Добавить интерактивнось) и нажмите Save.
5. Выйдите из Excel.
6. Откройте получившийся файл в MS Internet Explorer 4/5.
7. Прокрутите вниз до строки 2000, колонки WC.
8. Выделите строку 2000 целиком и нажимайте Tab, пока колонка WC снова не выделится.
9. Удерживая нажатыми Shift - Ctrl - Alt щелкните мышкой по логотипу Microsoft в левом верхнем углу.
10. Используйте стрелки для управления машинкой, пробел для стрельбы, H - для включения фар, а О - для масла.
11. Выход из игры по Esc.


WORD: Общие советы

Чтобы не загружать огромный и медленный Word, можно применить следующий трюк. Откройте Проводник. Далее Сервис-Свойства папки. Выбираете в списке файлов расширение *.DOC (Документ Microsoft Word). Нажимаете кнопку Дополнительно. В открывшемся окне выбираем кнопку Создать. Появится еще одно окно, в котором пишем для поля Действие - "Открыть Wordpad'ом", а в поле Приложение, исполняющее действие - C:\Progra~1\Access~1\WORDPAD.EXE "%1". Теперь, при нажатии на doc-файле вы увидите в контекстном меню строч ку " Открыть Wordpad'ом". Аналогично можно вносить и другие улучшения для удобства работы с файлами.

Если вы не хотите, чтобы инициалы вашего босса в отчете улетели на другую строку, оторвавшись от фамилии, а слово руб было на другой странице после цифры - количества этих самых рублей, то используйте неразрывные пробелы - в Word'е они вставляются по сочетанию клавиш [Ctrl] + [Shift] + [Пробел]. То есть сочетание, например, слов Билл (Ctrl + Shift + Пробел) Гейтс всегда будет на одной строке, в отличие от Билл(пробел)Гейтс

Наиболее часто встречающиеся опечатки исправит функция Автозамена (Сервис - Автозамена). Если существует слово, которое часто вводится неправильно, можно ввести в окне Автозамены правильную и неправильную версии его написания. После того, как это будет сделано, Word будет исправлять ошибку автоматически, не спрашивая разрешения пользователя. Кстати говоря, Автозамену можно использовать не только для устранения опечаток, но и для быстрого ввода каких-нибудь слов и предложений. Так, например, если вам часто приходится набирать фразу "Microsoft Office", введите ее в окне Автозамены как правильный вариант, а как неправильный - Mic. Теперь после набора этих трех букв появится целая фраза.

Microsoft Word запоминает около тридцати действий пользователя. Их можно отменить последовательно или же все сразу. Нажмите на стрелку, расположенную справа от кнопки Отменить, и выберите количество отменяемых действий. Ну, а для тех, кто умудряется ошибаться даже при исправлении ошибок, предусмотрена функция Вернуть (Redo), позволяющая отменить отмененные действия (извините за каламбур). Кнопка Вернуть также находится на панели инструментов, а с клавиатуры эта функция вызывается через CTRL+Y

Если в Word'е нажать Ctrl и крутить скроллинговое колесико мыши, то будет увеличиваться или уменьшаться масштаб с которым отображается лист на экране.

Если вы работаете с большим количеством документов, загруженных в Word, постоянно изменяя многие из них, но вполне может возникнуть ситуация, что вам, скажем, надо срочно отойти от компьютера. Естественно, есть опасения, что в случае, когда наступит сбой в электропитании или иная неприятная ситуация, может произойти потеря несохраненных данных. Но как сохранить все документы? По одному - но их много, и время уйдет немало. Закрыть Word и посохранять все по очереди? Тоже не быстро. Лучше нажмите Shift и кликните мышью на меню Файл - вы увидите там новый пункт меню: Сохранить все (или Закрыть все), который и следует выбрать в такой ситуации

Иногда, при наборе текста, забывают отключить клавишу CAPS LOCK, и тогда весь текст идет большими буквами. Или наоборот. Можно не поднимая головы напечатать приличный кусок текста не теми буквами. Что делать?
Выделите строку или абзац или весь текст. Удерживая клавишу Shift, кликайте на F3, тогда в зависимости от того какими буквами у вас набрано, будет меняться или первая буква, или на второй клик на F3 весь текст. Очень помогает и сберегает нервы.

Word запоминает и хранит в документе последние три места, где вводился или редактировался текст. Чтобы вернуться к одной из этих трёх позиций, нажмите нужное количество раз комбинацию клавиш "Shift"+"F5". При четвёртом нажатии курсор переместится на исходную позицию. Благодаря этому, при открытии уже имеющегося документа для возврата к месту, где работа была прервана, достаточно нажать "Shift"+"F5".

В больших Вордовских документах очень удобно ставить метки на различные места документа, выделяя ключевые слова цветом. Затем, чтобы быстро попасть в нужное место, откройте диалог поиска, нажмите кноку "Больше" для отображения всех функций поиска, и нажав кнопку "Формат" выбирите пункт "Выделение цветом" (в поле "Найти" должно быть пусто).

В Word'e можно перемещаться по предложениям назначив команде SentLeft и SentReght комбинации клавиш (Например, выбираем меню СЕРВИС, НАСТРОЙКА:, КЛАВИАТУРА:, в Категории: выбираем ВСЕ КОМАНДЫ, и в категории КОМАНДЫ находим нужную команду, назначаем клавиши и готово). Также можно и выделять по предложениям назначив командам SentLeftExtend и SentReghtExtend соответствующие комбинации клавиш.

В Word'e можно перемещать строки в тексте. Для этого надо выделить фрагмент текста, затем удерживая клавиши Shift+Alt перемещать его с помощью клавиш управления курсором "Стрелка вверх" и "Стрелка вниз". Переносить можно только строки целиком. А если удерживая эти клавиши нажимать "Стрелка вправо" или "Стрелка влево", можно менять стиль заголовка выделенного фрагмента.

Как ввести полужирный или наклонный текст в MS Word, не пользуясь мышью?
1. Поставить на всех вкладках автоформата (в Word 2000: Сервис|Автозамена) поставить галочки Заменять *полужирный* и _наклонный_.
2а. Если Вы хотите ввести полужирный текст, то его надо заключить в звездочки (*).
2б. Если Вы хотите ввести наклонный текст, то его надо заключить в символы подчеркивания (_).

Иногда Вам может попасть текст в MS Word который либо очень неумело набирали, либо коряво конвертировали из "Plain Text". В таком тексте в конце каждой строки стоит знак конца абзаца, а выравнивание сделано набором бесконечного числа пробелов. Такой текст форматировать очень сложно, при изменении размера бумаги, шрифта или отступов текст расползается в разные стороны и выглядит очень неаккуратно. Простые манипуляции в 5 минут приведут Ваш текст в гораздо более удобный для восприятия.
1. Выбираем "Replace" (Ctrl-H). В "Find What" ставим два пробела, в "Replace With" ставим 1 пробел, нажимаем "Replace All". Повторяем "Replace All" до тех пор, пока есть что-то что заменять. Все, от лишних пробелов мы избавились.
2. Теперь с абзацами. Выбираем "Replace" (Ctrl-H). В "Find What" ставим "^p^t" - т.е. поиск конца параграфа + табуляция, заменяем на "^l^t" - т.е. на переход на другую строку + табуляция - это будут наши начала абзацев.
3. Избавляемся от всех концов абзацев заменяя все "^p" на один пробел.
4. Формируем абзацы - заменяем все "^l" на "^p".
Все, теперь текст гораздо более близок к формату MS Word и над ним можно выполнять стандартные команды форматирования.

Если вы набираете текст и используете несколько шрифтов, им можно назначить комбинации клавиш в меню СЕРВИС, НАСТРОЙКА:, КЛАВИАТУРА:, в Категории: выбираем ШРИФТЫ, находим шрифт, назначаем клавиши.

Если вам нужно добавить сноску в документ, поместите курсор там, где вы хотите ее добавить и выберите Вставка -> Ссылка -> Сноска. В диалоговом окне Сноски в группе "Положение" выберите переключатель "сноски:" и нажмите кнопку Вставить. Напечатайте свою сноску в текстовой области, которая появится внизу страницы.

Если вам нужно, чтобы Word-2000 напечатал книжку на листах формата А4 с двух сторон по две страницы формата А5 на каждой стороне листа, то выберите: Файл -> Параметры страницы -> Зеркальные поля -> ОК ; Файл -> Печать -> (Масштаб)_число страниц на листе -> 2 страницы: (Страницы)_номера -> 16,1,2,15,14,3,4,13,12,5,6,11,10,7,8,9 - для 1 блока по 16 стр. 32,17,18,31,30,19,20,29,28,31,22,27,26,23,24,25 - для 2 блока по 16 стр. и т.д.
Вся книжка будет состоять из блоков по 16 страниц, напечатанных на 4 листах А4 с двух сторон. Листы перегибаются пополам и вкладываются друг в друга по номерам страниц.
Последний блок в книжке может быть укороченным и состоять из 3, 2 или 1 листа, поэтому и номера страниц для него нужно пересчитать отдельно.
Такую книжку удобно переплести как настоящую из типографии. Более подробно об этом можно прочитать в интересной и обстоятельной статье по адресу: http://klirik.narod.ru/izdat/articles/sp.htm

Чтобы комфортнее работать в Word'e при наборе большого текста перейдите к просмотру документа Меню ВИД, ОБЫЧНЫЙ (Ctrl+Alt+N), а для просмотра документа постранично Меню ВИД, РАЗМЕТКА СТРАНИЦЫ (Ctrl+Alt+P).


Word: Выделение текста

Выделение текста

Стандартные способы выделения текста
Для того, чтобы выделить предложение, нужно кликнуть на любом его слове при нажатой клавише CTRL. Если требуется выделить слово, на нем достаточно два раза щелкнуть мышью. Если щелкнуть три раза, выделится текущий абзац.

Способы выделения текста, используя отступ документа
Клик левой клавишей мышки на левом отступе документа:

  1. Одинарный - выделить строку
  2. Двойной - выделить абзац
  3. Тройной - выделить весь текст.
  4. Одинарный при нажатом Ctrl - выделить весь текст. Последнюю операцию можно проделать также с помощью клавиш CTRL+A.

Если нажать ALT и начать выделение мышкой, то будет выделяться прямоугольный фрагмент текста

Чтобы выделить весь абзац, нужно поставить курсор в начало или конец абзаца и нажать Ctrl+Shift+стрелка вверх (если курсор стоит в конце абзаца), Ctrl+Shift+стрелка вниз (если курсор стоит в начале абзаца).

Проблемой многих является выделение большого участка, ведь при достижении указателем нижнего края окна документ начинает прокручиваться быстро, и остановить его в нужном месте очень непросто. Поэтому для выделения больших участков текста используйте клавишу Shift. Если она нажата, вы легко сможете выделить любой участок.

Многократное выделение.
Как быть, если тот текст, в котором надо провести замену, разбросан по всему документу? Тут бы подошло многократное выделение. В WordXP такая возможность есть - достаточно при выделении нового фрагмента удерживать клавишу Ctrl, и имеющееся выделение сброшено не будет

Копировать и перемещать участки текста можно не только с помощью буфера обмена. В рамках небольшого участка документа эти операции можно выполнять мышкой. Для перемещения выделите нужный участок и наведите на него курсор. Нажмите кнопку мыши и, не отпуская ее, потяните курсор на то место, куда необходимо вставить текст. Когда вы отпустите кнопку мыши, текст будет перемещен. Чтобы при помощи мышки скопировать текст, необходимо выполнять те же действия при нажатой кнопке CTRL. При этом возле курсора появится значок +.


WORD: Горячие клавиши

Горячие клавиши и комбинации клавиш

Чтобы выделить в Word'е вертикальный блок текста, надо предварительно нажать комбинацию клавиш "Ctrl"+"Shift"+"F8". Кроме того, выделить вертикальный блок можно с помощью мышки, удерживая клавишу "Alt".

В Word работая в режиме кириллицы, иногда нужны знаки которые доступны лишь в режиме латиницы напр. @, $, & чтобы не переключать режимы достаточно нажать клавишу Alt + Ctrl + нужную (или Shft+Alt+Ctrl+нужная).

Горячие клавиши

  • Полужирный текст - нажимаем Ctrl+B (или в русскоязычном режиме - Ctrl+И). Выключается аналогично.
  • Курсивный текст - Ctrl+I или Сtrl+Y (в русском - Ctrl+Ш или Ctrl+Н).
  • Подчёркнутый текст - Ctrl+U (в русском - Ctrl+Г)
  • Текст с двойным подчёркиванием - Ctrl+Shift+D (Ctrl+Shift+в)
  • Текст, набранный капителями (уменьшенными заглавными буквами) - Ctrl+Shift+K (Ctrl+Shift+Л) (для изменения данных атрибутов у целого слова, его вовсе не обязательно выделять целиком. Достаточно лишь, чтобы курсор находился внутри слова).
  • Выравнивание абзацев: влево - Ctrl+q (Ctrl+й);
  • вправо - Ctrl+r (Ctrl+к);
  • по центру - Ctrl+e (Ctrl+у)
  • по формату - Ctrl+j (Ctrl+о)
  • маркированный список - Ctrl+Shift+L (Ctrl+Shift+д)
  • Сдвиг абзаца вправо Ctrl+M (Ctrl+ь)
  • Увеличение отступа слева (кроме первой строки) - Ctrl+T (Ctrl+е)
  • Печать документа (в Word и почти во всех других программах) - Ctrl+P (ctrl+З).

Несколько полезных замечаний для тех, кто печатает вслепую и ненавидит использовать мышь:
Изменить шрифт в тексте - нажимаем Ctrl+Shift+F (Ctrl+Shift+А), при этом активизируется окно смены шрифта в панели форматирования. Печатаем название нужного шрифта в этой панели (обычно достаточно нескольких первых символов - далее Windows достраивает имя автоматичеки) и нажимаем "Ввод".
Изменить стиль шрифта или абзаца - аналогично, нажимаем Ctrl+Shift+S (Ctrl+Shift+Ы), и вводим имя шрифта, например, "Заголовок 1". После нажатия "Ввод", к абзацу применяется введённый стиль, а если стиля не существует, то он создаётся на основании форматирования абзаца, где стоит курсор.
Ввод концевой сноски. Можно, конечно, для этого лезть в меню, но это опять подразумевает использование мыши! Гораздо проще нажать Ctrl+Alt+F (Ctrl+Alt+А), и в указанном месте текста сразу появится сноска, а курсор переместится к низу страницы, где вы сможете ввести её описание.

Очень легко удалить неиспользуемые кнопки с панели, просто вытащив их с панели мышкой при нажатом Alt, точно так же при нажатом Alt можно поменять расположение кнопок не залезая в окна опций и настроек (с нажатым Alt+Ctrl - можно сделать копию кнопки). Такими же манипуляциями можно кнопки поместить в меню и разделы меню в toolbar с кнопками.

Иногда возникает проблема и нужно изменить регистр букв, для этого становимся на слове в котором нужно изменить регистр (или выделяем несколько слов) и нажимаем Shift+F3 несколько раз, в зависимости как вы хотите: Все Буквы Большие В Начале Слов, ПРОПИСНЫЕ или строчные.


Word: Пасхальное яйцо

Если в Word'e зайти в меню "Справка-О программе" и удерживая Shift - Ctrl - Alt нажать левой кнопкой мыши один раз на разделительную полосу, то появится логотип MS Word, убрать который можно только нажав по нему левой кнопкой мыши

Создайте новый документ и введите там строку =rand(200,99)
Затем нажмите и удерживайте Enter в течение 2-3 секунд. Появится фраза "Съешь ещё этих мягких французских булок, да выпей чаю.", сколько раз - считайте сами :).

Еще одна игрушка в Word97, из не документированных возможностей - Pinbаll:
1.Открыть Word. Создать новый документ.
2.Напечатать слово Blue, выделить его.
3.Выбрать в меню ФОРМАТ-ШРИФТ.Задать полужирное начертание и синий цвет.
4.Поместить курсор в конец слова Blue ввести один пробел.
5.Выбрать Помощь (или у меня, например,?) - О программе и удерживая CTRL+SHIFT щелкнуть левой кнопкой мыши по значку Word в иллюстрации на левой чаcти появившегося окна.
6. Клавиши Z - для удара левой лопаткой, M - для удара правой, Esc - выход.


Железо

Hardware: Общие советы

Чтобы отключить встроенный динамик в Windows XP (достал, однако), то заставить спикер замолчать можно следующим образом. Для этого в "Диспетчере устройств" (Панель управления-Система-Оборудование) в меню "Вид" поставьте флажок напротив пункта "Показать скрытые устройства". Далее в появившейся ветви "Драйверы устройств не Plug and Play" найдите устройство с именем Beep и отключите его.

Если внешний модем не ставить на системный блок, а сам системный блок заземлить то скорость увеличивается процентов на 10-15.

Существуют вирусы (например, Win95.CIH), которые уничтожают содержимое Flash BIOS, записывая в него случайные данные ("мусор"). В результате после первой же перезагрузки компьютер перестаёт загружаться. И, как правило, даже в промышленных условиях восстановить содержимое Flash BIOS и вернуть работоспособность компьютеру достаточно сложно. Я РЕКОМЕНДУЮ всем пользователям современных компьютеров установить ПЕРЕКЛЮЧАТЕЛЬ на материнской плате компьютера в положение, запрещающее ЗАПИСЬ во Flash BIOS! Иначе вы можете НАВСЕГДА ПОТЕРЯТЬ свой компьютер!

Иногда надо замедлить компьютер для некоторых старых программ или для отладки и тестирования собственных программ на слабом компьютере. Можно, конечно, скачать довольно большое количество замедлялок, но можно обойтись и без них. Если у Вас в BIOS есть опции "Internal Cashe" и "External Cashe" отключите их (обе или какую-нибудь одну) что обеспечит снижение быстродействия минимум на порядок.

Если вы пришли к другу, а он хвастается своими наворотами, когда он отлучится на минутку-другую, зайдите: ПУСК>Выполнить>В окно напишите "system.ini">выполнить, перед вами появится документ, впишите в него следующие слова:
[MathCoprocessor]
FPUFlags=2
Вот и всё. После того как ваш друг перезагрузит свой комп, комп станет большим тугодумом.
Но не забудте после этого зайти туда и стереть написанное.
После перезагрузки всё в порядке.

Иногда, безнадежно испорченный CDRom все же можно прочитать. Несколько CD мне удалось восстановить следующим способом:
1. Делаем образ CDDisk на Hard Drive с помощью какой-нибудь программы для записи CD, они работают на низком уровне, не читая файловую систему, а сбрасывая весь диск как есть в файл. У меня лично наилучшие результаты давал NTI CD Maker, но если он не читает или читает с ошибкой, то надо пробовать и другие програмы - Clone CD, Easy CD Creator, Nero и CDRWin - если не помогает одна программа, то есть вероятность что поможет другая. Если у Вас несколько CD приводов то надо попробовать читать с каждого, в общем случае лучше диски читают CDR приводы, хуже CD и совсем плохо DVD, хотя возможны и исключения - купленный мной DVDROM на удивление читает диски, которые даже CDR не хочет читать ни в какую, но базируясь на своем опыте могу сказать, что это скорее исключение чем правило. Если есть выбор то лучше создавать образ в формате ISO - это стандарт, с которым работают почти все программы.
2. Если вы получили image то с большой вероятностью можно восстановить и файлы. Способов два. Первый - из image запишите диск (лучше использовать CDRW чтоб не портить болванку если что-нибудь не будет работать, причем записывать диск надо той же программой, которой вы создали image - несмотря на стандартность форматов, всеж таки не все там чисто и далеко не всегда можно записать диск из image чужой программы), второй способ - можно извлечь файлы прямо из image при помощи следующих программ - ISOBuster, WinISO (ShareWare - широко доступны в интернете, в новых версиях возожноти примерно одинаковые, возможно ISOBuster работает чуть аккуратнее, но новую версию WinISO я еще не тестировал), те же кто пользует Windows Commander могут воспользоваться бесплатным plug-in для ISO файлов, который позволяет работать с ними как с обычными архивами (доступен для скачки на официальном сайте Windows Commander).

Если у вас есть компакт-диск, который не читается из-за царапин на поверхности, можно попытаться оживить одноглазого (конечно, если царапины сделаны не гвоздем или наждачкой :)). Для этого на мягкую тряпочку (лучше всего фланелевую) нанести немного зубной пасты и попытаться заполировать царапины. Несколько дисков таким образом мне удалось восстановить.


BIOS

Несколько простых советов по оптимизации BIOS для ускорения загрузки и работы компьютера:
1. Заходим в BIOS, так как они все разные, то я не могу сказать точно расположение и названия опций, как и гарантировать их наличие, но рассматриваемые опции довольно стандартны и присутствуют на большинстве компьютеров. Итак сразу после рестарта компьютера заходим в BIOS (обычно по нажатию Delete, реже F2, F1, Ctrl-Esc).
2. Находим последовательность устройств для загрузки (Boot Sequence или что-то подобное). Ставим первым HDD-0 или IDE-0, т.е. Ваш основной винчестер, все остальные устройства (с 2го по 4й) отключаем (если у Вас появится необходимость загрузиться с дискеты или CDROM то вам будет необходимо вновь изменить эти опции, впрочем на многих материнках есть одна недокументированная опция - нажатие несколько раз Esc во время загрузки когда идет автоопределение жестких дисков - приводит к появлению меню загрузки с разных устройств).
3. Отключаем Boot Other Device - Вам не надо чтоб BIOS искал чего-то при загрузке.
4. Отключаем Boot up Floppy Seek - не дергать дисковод при загрузке.
5. Если Вы не используете USB порт, целесообразно поставить его в Disable в BIOS - это предотвращает его опрос в момент загрузки и загрузку в Виндах его драйвера, который все равно не используется.
6. Ставим Enable Fast Boot, Fast memory test, если у Вас есть эти опции.
7. Если есть возможность, надо так же сделать автоопределение винчестеров и CDROM'ов в BIOS и запомнить их, чтоб BIOS каждый раз их не тестировал.
8. Отключите проверку на вирусы.
Сохраняем изменения и готово - если у Вас стояли какие-нибудь другие опции, вы получите существенное ускорение загрузки компьютера, подчас в 2-3 раза. Разумеется эта конфигурация для повседневной работы, если же Вам надо отлаживать компьютер или переустанавливать операционку, то скорее всего Вам придется поставить что-то другое.


Авторы советов

Данный справочник является плодом сотрудничества Игоря Чеботарева и Александра Климова. При его составлении использовались самые полезные и популярные на наш взгляд советы, присланные для рубрики Народная мудрость сайта http://www.whatis.ru/. Авторство советов сохранено на том сайте. Здесь же приводится список наиболее активных советчиков, указавших либо свое полное имя, либо свой ник с электронным адресом. Если вы хотите, чтобы и ваше имя попало в справочник, присылайте свои советы на наш сайт и указывайте свои координаты.

TOP-20 наиболее активных участников

  1. Алексей (Sebulba)
  2. Crazy_Serg
  3. Ярослав Будниченко
  4. Сергей Трошин (http://www.computery.ru/upgrade/ )
  5. Евгений Соболев (http://www.softodrom.ru)
  6. Soobcha.ru
  7. Korsar
  8. Ольга КАЛИТКА
  9. 0X0THuK (http://www.rotten7.narod.ru)
  10. Alex
  11. Руслан
  12. Петков Дима
  13. Snowflake
  14. Eugene KRUGLOFF
  15. ffaster
  16. Алексеев Виктор
  17. kpblc
  18. N. Noskow
  19. Артем Захаров
  20. O1eg (http://www.hostsearch.ru/)


Специальные символы

С помощью клавиатуры можно ввести различные символы, которых нет на самой клавиатуре.
Для того чтобы поставить знак промилле (показывающий уровень солености), нужно при любой раскладке клавиатуры удерживая Alt на цифровой клавиатуре нажать 0137, затем отпустить Alt и должно получится - ‰
Для того чтобы поставить знак параграфа, нужно при любой раскладке клавиатуры, удерживая Alt на цифровой клавиатуре нажать 789, затем оптпустить Alt и должно получится - §.
Чтобы поставить знак "•" (без кавычек), надо удерживая Alt на дополнительной клавиатуре нажать 0321456789. Получится - •.

У многих пользователей до сих пор старые клавиатуры, на которых нет значка "ЕВРО". В Win98/ME/2000/XP есть возможность ввести с клавиатуры этот значок.
Он отображается, только если используемый шрифт содержит его.
Нажмите и удерживайте ALT, наберите на дополнительной цифровой клавиатуре 0136 и отпустите ALT. Значок должен появиться.


rundll32.exe

Местонахождение

Windows\system32

Описание

Run a DLL as an App

Windows имеет в своем составе утилиту командной строки rundll32.exe, которая позволяет запускать некоторые команды-функции, заложенные в DLL-файлах.

Вообще-то данная утилита была разработана для внутреннего пользования программистами Microsoft. Но богатые возможности этой программы дало повод на всеобщее использование пользователями.

Область применения данной утилиты довольно широк. Вы можете вводить приведенные ниже команды в окне Запуск программы (Пуск-Выполнить), также создать ярлыки с заданнами параметрами запуска, использовать в коде на программируемом вами языке (C++, Delphi, Visual Basic и т.д.)

Список команд слишком обширен. Приведем список наиболее значимых команд.

  • rundll32 shell32.dll,Control_RunDLL hotplug.dll - диалоговое окно Отключение или извлечение аппаратного устройства
  • rundll32 diskcopy,DiskCopyRunDll - вызов диалога "Копирование диска".
  • rundll32 keyboard,disable - отключение клавиатуры, действует до следующей перезагрузки.
  • rundll32 mouse,disable - отключение мыши вплоть до перезагрузки.
  • rundll32 krnl386.exe,exitkernel - выгрузить ядро системы, выход из Windows.
  • rundll32 mshtml.dll,PrintHTML "HtmlFileNameAndPath" - распечатать документ HTML, где "HtmlFileNameAndPath" - путь к файлу и его имя.
  • rundll32 мсprint2.dll,RUNDLL_PrintTestPage - распечатать тестовую страницу на принтере.
  • rundll32 netplwiz.dll,AddNetPlaceRunDll - вызов мастера подключения нового сетевого ресурса "Добавление в сетевое окружение".
  • rundll32 rnaui.dll,RnaWizard - вызов мастера "Удаленный доступ к сети".
  • rundll32 rnaui.dll,RnaWizard /1 - вызов мастера "Удаленный доступ к сети" без отображения начального окна.
  • rundll32 shell,ShellExecute - открыть Проводник (папка "Рабочий стол").
  • rundll32 shell32,Control_RunDLL - открыть в Проводнике папку "Панель управления".
  • rundll32 shell32,Control_RunDLL appwiz.cpl,,n - вызов диалогового окна "Установка и удаление программ", в котором будет открыта вкладка с номером "n" (от 1 до 3).
  • rundll32 shell32,Control_RunDLL main.cpl @0 - открыть диалог "Свойства мыши".
  • rundll32 shell32,Control_RunDLL main.cpl @1 - открыть диалог "Свойства клавиатуры".
  • rundll32 shell32,Control_RunDLL main.cpl @2 - открыть папку "Принтеры".
  • rundll32 SHELL32,SHHelpShortcuts_RunDLL PrintersFolder - открыть папку "Принтеры" (другой способ).
  • rundll32 shell32,Control_RunDLL main.cpl @3 - открыть папку "Шрифты".
  • rundll32 SHELL32,SHHelpShortcuts_RunDLL FontsFolder - открыть папку "Шрифты" (другой способ).
  • rundll32 SHELL32,Control_RunDLL modem.cpl, add - открыть диалог "Свойства модема".
  • rundll32 shell32,Control_RunDLL timedate.cpl - открыть диалог "Дата и время".
  • rundll32 shell32,OpenAs_RunDLL - вызвать диалог "Открыть с помощью...".
  • rundll32 shell32,ShellAboutA WINHOWTO.RU - информация о версии Windows.
  • rundll32 shell32,SHExitWindowsEx 0 - закрыть все программы, перегрузить оболочку.
  • rundll32 shell32, SHExitWindowsEx 1 - выключить ПК.
  • rundll32 SHELL32, SHExitWindowsEx -1 - перегрузить оболочку Windows.
  • rundll32 shell32, SHExitWindowsEx 2 - перегрузить ПК.
  • rundll32 shell32,SHExitWindowsEx 4 - принудительно закрыть все программы.
  • rundll32 shell32,SHExitWindowsEx 8 - выход из Windows и выключение ATX-совместимого ПК.
  • rundll32 shell32,SHFormatDrive - вызов диалога форматирования диска А:.
  • rundll32 SHELL32,SHHelpShortcuts_RunDLL AddPrinter - запуск "Мастера установки принтера".
  • rundll32 shell32,SHHelpShortcuts_RunDLL Connect - запуск мастера подключения сетевого диска.
  • rundll32 SHELL32,SHHelpShortcuts_RunDLL PrintTestPage - распечатать тестовую страницу.
  • rundll32 sysdm.cpl,InstallDevice_Rundll - вызов мастера установки оборудования.
  • rundll32 url.dll,FileProtocolHandler %1 - открыть веб-страницу, где %1 - URL сайта (включая http://).
  • rundll32 url.dll,MailToProtocolHandler %1 - создать новое письмо, где %1 - e-mail адресата.
  • rundll32 user,CASCADECHILDWINDOWS - расположить все окна каскадом.
  • rundll32 user,TILECHILDWINDOWS - расположить все окна по экрану.
  • rundll32 user,disableoemlayer - сбой системы (!) - выключить все функции ввода-вывода (клавиатура, дисплей, мышь). В результате будет черный экран с курсором и ни на что не реагирующая система, однако Windows продолжает работать.
  • rundll32 user,ExitWindowsExec - быстрая перезагрузка Windows.
  • rundll32 user,RepaintScreen - выполнить команду "Обновить".
  • rundll32 user,SetCaretBlinkTime n - задать частоту мигания курсора, соответствующую значению параметра n.
  • rundll32 user,SetCursorPos - переместить курсор мыши в верхний левый угол экрана.
  • rundll32 user,SetDoubleClickTime n - задать скорость двойного нажатия левой кнопки мыши (Double Click), соответствующую параметру n.
  • rundll32 user,SwapMouseButton - поменять местами клавиши мыши (обратная смена невозможна).
  • rundll32 user,WNetConnectDialog - вызов диалога "Подключение сетевого диска".
  • rundll32 user,WNetDisconnectDialog - вызов диалога "Отключение сетевого диска".
  • rundll32 AppWiz.Cpl,NewLinkHere %1 - запуск мастера создания нового ярлыка, где %1 - путь к исходному файлу.


SFC.EXE

Местонахождение

Windows\system32

Описание

Windows 2000 System File Checker

Утилита SFC.EXE предназначена для проверки всех версий защищенных системных файлов и восстановления их из специального кэша в случае подмены или повреждения.

В Windows XP она запускается только из командной строки - в отличие от Windows 9х, где подобная утилита имеет графический интерфейс. Запуск утилиты возможен только с правами администратора, синтаксис такой:
sfc [/scannow] [/scanonce] [/scanboot] [/revert] [/cancel] [/enable] [/purgecache] [/cache size=x] [/quiet]

Параметры командной строки, которые можно задавать для программы SFC, следующие:

  • /scannow - немедленная проверка всех защищенных системных файлов
  • /scanonce - проверка защищенных системный файлов при следующей загрузке системы
  • /scanboot - проверка всех защищенных системных файлов при каждой загрузке системы
  • /revert - восстанавливает все настройки по умолчанию (Windows XP)
  • /cancel - отменяет все проверки защищенных системных файлов (Windows Me/2000)
  • /purgecache - очистка кэша защищенных файлов программы и немедленная проверка всех защищенных системных файлов
  • /cachesize=x - установка размера кэша защищенных файлов в мегабайтах (по умолчанию 50 мГб)
  • /enable - включение защиты системных файлов Windows (Windows Me/2000)
  • /quiet - замена поврежденных файлов без предупреждения (Windows Me/2000)
  • /? - вызов справки

Давайте рассмотрим практическое применение утилиты.

Папка dllcache

Если вас не устраивает, что Windows XP занимает слишком много места и восстанавливает удалённые из его директории файлы, то может удалить папку dllcache, но после следующей проверки системных файлов Windows снова заполнит эту папку. Для устранения этого "греха", после удаления или до удаления файлов (но не папки), нужно запустить команду sfc /cachesize=число. Числом будет количество мегабайт которое должно резервироваться для папки windows\system32\dllcache. Можно поставить = 0.

Поврежденные файлы

Предположим, вы обнаружили, что на вашем компьютере отсутствуют некоторые файлы, например, шрифты (шрифты - тоже системные файлы). Проверяем наличие системных файлов с помощью команды
sfc.exe /scannow
Windows проверит файлы и при необходимости переустановит недостающие или поврежденные.